rb532: preserve commandline-patched kernel images for faster kernel testing via netboot
authorFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2009 00:45:28 +0000 (00:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2009 00:45:28 +0000 (00:45 +0000)
SVN-Revision: 15766

target/linux/rb532/image/Makefile

index a29ddf82807bfd3e6f0bd56dcc43d62621df8704..9d0857dec84c9ae10b27119ac2063742149624be 100644 (file)
@@ -54,8 +54,9 @@ root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
 endef
 
 define Image/Build
 endef
 
 define Image/Build
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
-       ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+       $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel
+       $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
+       ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
 endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
 endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)