Add lighttpd package
authorNicolas Thill <nico@openwrt.org>
Mon, 16 May 2005 18:41:16 +0000 (18:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 16 May 2005 18:41:16 +0000 (18:41 +0000)
SVN-Revision: 917

19 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/lighttpd/Config.in [new file with mode: 0644]
openwrt/package/lighttpd/Makefile [new file with mode: 0644]
openwrt/package/lighttpd/files/lighttpd.conf [new file with mode: 0644]
openwrt/package/lighttpd/files/lighttpd.default [new file with mode: 0644]
openwrt/package/lighttpd/files/lighttpd.init [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-alias.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-auth.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-cgi.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-proxy.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-redirect.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-rewrite.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-setenv.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-simple-vhost.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-status.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd-mod-usertrack.control [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd.conffiles [new file with mode: 0644]
openwrt/package/lighttpd/ipkg/lighttpd.control [new file with mode: 0644]

index 572589df17cf02b994010a49d78657da48b3d560..2fee04f3cc9f64c44e61168a9be8f23bbc162ba6 100644 (file)
@@ -67,6 +67,7 @@ source "package/siproxd/Config.in"
 source "package/sipsak/Config.in"
 source "package/htpdate/Config.in"
 source "package/howl/Config.in"
+source "package/lighttpd/Config.in"
 source "package/pmacct/Config.in"
 source "package/ulogd/Config.in"
 source "package/vsftpd/Config.in"
index 16a551e8d591ec2561265e4b933d139015ba7606..2de4eaf076a563affc54a8d126c5f126c0484ca0 100644 (file)
@@ -88,6 +88,7 @@ package-$(BR2_PACKAGE_SIPROXD) += siproxd
 package-$(BR2_PACKAGE_SIPSAK) += sipsak
 package-$(BR2_PACKAGE_HTPDATE) += htpdate
 package-$(BR2_PACKAGE_HOWL) += howl
+package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_OSIRISD) += osiris
 package-$(BR2_PACKAGE_PMACCT) += pmacct
 package-$(BR2_PACKAGE_ULOGD) += ulogd
@@ -140,6 +141,7 @@ cyrus-sasl-compile: openssl-compile
 openldap-compile: cyrus-sasl-compile openssl-compile
 siproxd-compile: libosip2-compile
 sipsak-compile: openssl-compile
+lighttpd-compile: openssl-compile pcre-compile
 osiris-compile: openssl-compile
 pmacct-compile: libpcap-compile
 
diff --git a/openwrt/package/lighttpd/Config.in b/openwrt/package/lighttpd/Config.in
new file mode 100644 (file)
index 0000000..a8ad10f
--- /dev/null
@@ -0,0 +1,72 @@
+config BR2_PACKAGE_LIGHTTPD
+       prompt "lighttpd - a flexible and lightweight web server"
+       tristate 
+       default m if CONFIG_DEVEL
+       help
+         A flexible and lightweight web server.
+         
+         http://www.lighttpd.net/
+         
+         Depends: libopenssl, libpcre
+         
+
+config BR2_PACKAGE_LIGHTTPD_MOD_ALIAS
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-alias - a directory alias module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_AUTH
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-auth - an authentication module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_CGI
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-cgi - a CGI module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_PROXY
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-proxy - a proxy module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_REDIRECT
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-redirect - an url redirection module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_REWRITE
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-rewrite - an url rewriting module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_SETENV
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-setenv - an environment variable setting module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_SIMPLE_VHOST
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-simple-vhost - a simple virtual hosting module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_STATUS
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-status - a server status display module"
+       tristate 
+       default m if CONFIG_DEVEL
+
+config BR2_PACKAGE_LIGHTTPD_MOD_USERTRACK
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "mod-usertrack - an user tracking module"
+       tristate 
+       default m if CONFIG_DEVEL
+
diff --git a/openwrt/package/lighttpd/Makefile b/openwrt/package/lighttpd/Makefile
new file mode 100644 (file)
index 0000000..7f0b0e7
--- /dev/null
@@ -0,0 +1,104 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lighttpd
+PKG_VERSION:=1.3.13
+PKG_RELEASE:=1
+PKG_MD5SUM:=2f017b936be376ad6f6c2ee26db93467
+
+PKG_SOURCE_URL:=http://www.lighttpd.net/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+define PKG_mod_template
+
+$$(IPKG_$(1)):
+       install -d -m0755 $$(IDIR_$(1))/usr/lib
+       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/mod_$(2).so $$(IDIR_$(1))/usr/lib/
+       $(RSTRIP) $$(IDIR_$(1))
+       $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
+
+endef
+
+$(eval $(call PKG_template,LIGHTTPD,lighttpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_PROXY,lighttpd-mod-proxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_REDIRECT,lighttpd-mod-redirect,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_REWRITE,lighttpd-mod-rewrite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_SETENV,lighttpd-mod-setenv,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_SIMPLE_VHOST,lighttpd-mod-simple-vhost,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_PROXY,proxy))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_REDIRECT,redirect))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_REWRITE,rewrite))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SETENV,setenv))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SIMPLE_VHOST,simple_vhost))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_STATUS,status))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_USERTRACK,usertrack))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               PCRE_LIB="-lpcre" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --enable-static \
+                 --with-openssl="$(STAGING_DIR)/usr" \
+       )
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_LIGHTTPD):
+       install -m0755 -d $(IDIR_LIGHTTPD)/etc
+       install -m0644 ./files/lighttpd.conf $(IDIR_LIGHTTPD)/etc/
+       install -m0755 -d $(IDIR_LIGHTTPD)/etc/default
+       install -m0644 ./files/lighttpd.default $(IDIR_LIGHTTPD)/etc/default/lighttpd
+       install -m0755 -d $(IDIR_LIGHTTPD)/etc/init.d
+       install -m0755 ./files/lighttpd.init $(IDIR_LIGHTTPD)/etc/init.d/lighttpd
+       install -m0755 -d $(IDIR_LIGHTTPD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/lighttpd $(IDIR_LIGHTTPD)/usr/sbin/
+       $(RSTRIP) $(IDIR_LIGHTTPD)
+       $(IPKG_BUILD) $(IDIR_LIGHTTPD) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/lighttpd/files/lighttpd.conf b/openwrt/package/lighttpd/files/lighttpd.conf
new file mode 100644 (file)
index 0000000..28f9e28
--- /dev/null
@@ -0,0 +1,175 @@
+# lighttpd configuration file
+# 
+## modules to load
+# all other module should only be loaded if really neccesary
+# - saves some time
+# - saves memory
+#server.modules              = ( 
+#                               "mod_rewrite", 
+#                               "mod_redirect", 
+#                              "mod_auth", 
+#                               "mod_status", 
+#                              "mod_simple_vhost",
+#                              "mod_evhost",
+#                              "mod_cgi",
+#                              "mod_compress",
+#                               "mod_ssi",
+#                               "mod_usertrack"
+#)
+
+## a static document-root, for virtual-hosting take look at the 
+## server.virtual-* options
+server.document-root             = "/www/"
+
+## where to send error-messages to
+# server.errorlog            = "/var/log/lighttpd/error.log"
+
+# files to check for if .../ is requested
+server.indexfiles          = ( "index.html", "default.html", 
+                                "index.htm", "default.htm" )
+
+# mimetype mapping
+mimetype.assign            = (  
+  ".pdf"          =>      "application/pdf",
+  ".class"        =>      "application/octet-stream",
+  ".pac"          =>      "application/x-ns-proxy-autoconfig",
+  ".swf"          =>      "application/x-shockwave-flash",
+  ".wav"          =>      "audio/x-wav",
+  ".gif"          =>      "image/gif",
+  ".jpg"          =>      "image/jpeg",
+  ".jpeg"         =>      "image/jpeg",
+  ".png"          =>      "image/png",
+  ".css"          =>      "text/css",
+  ".html"         =>      "text/html",
+  ".htm"          =>      "text/html",
+  ".js"           =>      "text/javascript",
+  ".txt"          =>      "text/plain",
+  ".dtd"          =>      "text/xml",
+  ".xml"          =>      "text/xml"
+ )
+
+# Use the "Content-Type" extended attribute to obtain mime type if possible
+# mimetypes.use-xattr = "enable"
+
+
+######### Options that are good to be but not neccesary to be changed #######
+
+## bind to port (default: 80)
+#server.port                = 81
+
+## bind to localhost (default: all interfaces)
+#server.bind                = "grisu.home.kneschke.de"
+
+## error-handler for status 404
+#server.error-handler-404   = "/error-handler.html"
+#server.error-handler-404   = "/error-handler.php"
+
+
+###### virtual hosts
+##
+##   If you want name-based virtual hosting add the next three settings and load
+##   mod_simple_vhost
+##
+## document-root =
+##   virtual-server-root + virtual-server-default-host + virtual-server-docroot or
+##   virtual-server-root + http-host + virtual-server-docroot
+##
+#simple-vhost.server-root         = "/home/weigon/wwwroot/servers/"
+#simple-vhost.default-host        = "grisu.home.kneschke.de"
+#simple-vhost.document-root       = "/pages/"
+
+
+## 
+## Format: <errorfile-prefix><status>.html
+## -> ..../status-404.html for 'File not found'
+#server.errorfile-prefix    = "/www/error-"
+
+## virtual directory listings
+#server.dir-listing          = "enable"
+
+## send unhandled HTTP-header headers to error-log
+#debug.dump-unknown-headers  = "enable"
+
+### only root can use these options
+#
+# chroot() to directory (default: no chroot() )
+#server.chroot            = "/"
+
+## change uid to <uid> (default: don't care)
+#server.username            = "nobody"
+
+## change uid to <uid> (default: don't care)
+#server.groupname           = "nobody"
+
+## to help the rc.script
+#server.pid-file            = "/var/run/lighttpd.pid"
+
+#### compress module
+#compress.cache-dir          = "/dev/null/"
+#compress.filetype           = ("text/plain", "text/html")
+
+#### fastcgi module
+## read fastcgi.txt for more info
+#fastcgi.server              = ( ".php" =>
+#                              ( "grisu" => 
+#                                ( 
+#                                  "host" => "192.168.2.10",
+#                                  "port" => 1026
+#                                )
+#                              )
+#                            )
+
+#### CGI module
+#cgi.assign                  = ( ".pl"  => "/usr/bin/perl",
+#                                ".cgi" => "/usr/bin/perl" )
+#
+
+#### SSL engine
+#ssl.engine                  = "enable"
+#ssl.pemfile                 = "server.pem"
+
+#### status module
+# status.status-url = "/server-status"
+# status.config-url = "/server-config"
+
+#### auth module
+## read authentification.txt for more info
+# auth.backend                = "plain"
+# auth.backend.plain.userfile = "lighttpd.user"
+# auth.backend.plain.groupfile = "lighttpd.group"
+
+# auth.require                = ( "/server-status" => 
+#                                ( 
+#                                "method"  => "digest",
+#                                "realm"   => "download archiv",
+#                                "require" => "group=www|user=jan|host=192.168.2.10"
+#                              ),
+#                              "/server-info" => 
+#                                ( 
+#                                "method"  => "digest",
+#                                "realm"   => "download archiv",
+#                                "require" => "group=www|user=jan|host=192.168.2.10"
+#                              )
+#                              )
+
+#### url handling modules (rewrite, redirect, access)
+# url.rewrite                 = ( "^/$"             => "/server-status" )
+# url.redirect                = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
+
+#
+# define a pattern for the host url finding
+# %% => % sign
+# %0 => domain name + tld
+# %1 => tld
+# %2 => domain name without tld
+# %3 => subdomain 1 name
+# %4 => subdomain 2 name
+#
+# evhost.path-pattern = "/home/storage/dev/www/%3/htdocs/"
+
+#### expire module
+# expire.url                  = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")
+
+#### ssi
+# ssi.extension              = ( ".shtml" )
+
diff --git a/openwrt/package/lighttpd/files/lighttpd.default b/openwrt/package/lighttpd/files/lighttpd.default
new file mode 100644 (file)
index 0000000..649571e
--- /dev/null
@@ -0,0 +1 @@
+OPTIONS="-f /etc/lighttpd.conf"
\ No newline at end of file
diff --git a/openwrt/package/lighttpd/files/lighttpd.init b/openwrt/package/lighttpd/files/lighttpd.init
new file mode 100644 (file)
index 0000000..ca7a3f9
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+BIN=lighttpd
+DEFAULT=/etc/default/$BIN
+LOG_D=/var/log/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  mkdir -p $LOG_D
+  mkdir -p $RUN_D
+  $BIN $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-alias.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-alias.control
new file mode 100644 (file)
index 0000000..bdf72d3
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-alias
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: a directory alias module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-auth.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-auth.control
new file mode 100644 (file)
index 0000000..8b20497
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-auth
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: an authentication module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-cgi.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-cgi.control
new file mode 100644 (file)
index 0000000..c45edee
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-cgi
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: a CGI module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-proxy.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-proxy.control
new file mode 100644 (file)
index 0000000..934ecac
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-proxy
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: a proxy module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-redirect.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-redirect.control
new file mode 100644 (file)
index 0000000..e907e6d
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-redirect
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: an url redirection module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-rewrite.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-rewrite.control
new file mode 100644 (file)
index 0000000..c849482
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-rewrite
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: an url rewriting module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-setenv.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-setenv.control
new file mode 100644 (file)
index 0000000..d623321
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-setenv
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: an environment variable setting module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-simple-vhost.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-simple-vhost.control
new file mode 100644 (file)
index 0000000..d4381f4
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-simple-vhost
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: a simple virtual hosting module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-status.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-status.control
new file mode 100644 (file)
index 0000000..cd03a57
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-status
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: a server status display module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-usertrack.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-usertrack.control
new file mode 100644 (file)
index 0000000..5c484de
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-usertrack
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: an user tracking module for lighttpd
+Depends: lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd.conffiles b/openwrt/package/lighttpd/ipkg/lighttpd.conffiles
new file mode 100644 (file)
index 0000000..6c127a4
--- /dev/null
@@ -0,0 +1,3 @@
+/etc/lighttpd.conf
+/etc/default/lighttpd
+/etc/init.d/lighttpd
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd.control b/openwrt/package/lighttpd/ipkg/lighttpd.control
new file mode 100644 (file)
index 0000000..a318f7f
--- /dev/null
@@ -0,0 +1,10 @@
+Package: lighttpd
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/lighttpd/
+Description: a flexible and lightweight web server,
+ built with SSL support.
+Depends: libopenssl, libpcre