image.mk: make image too big warnings more visible
authorJonas Gorski <jogo@openwrt.org>
Mon, 25 May 2015 08:27:55 +0000 (08:27 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 25 May 2015 08:27:55 +0000 (08:27 +0000)
Output warnings through stderr to allow them to be easilier spotted
when building with V=w.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45746

include/image.mk

index 921d78d10d7b52e578b253c13f829ee48c2055dd..f6f30c59b01374820c07a5a4c2f9e2d1c33c4042 100644 (file)
@@ -321,7 +321,7 @@ endef
 
 define Build/check-size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \
-               echo "WARNING: Image file $@ is too big"; \
+               echo "WARNING: Image file $@ is too big" >&2; \
                rm -f $@; \
        }
 endef
@@ -378,7 +378,7 @@ endif
 
 define Device/Build/check_size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \
-               echo "WARNING: Image file $@ is too big"; \
+               echo "WARNING: Image file $@ is too big" >&2; \
                rm -f $@; \
        }
 endef