set the umask in toplevel.mk instead of forcing the user to adjust it
authorFelix Fietkau <nbd@openwrt.org>
Thu, 14 Oct 2010 15:53:47 +0000 (15:53 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 14 Oct 2010 15:53:47 +0000 (15:53 +0000)
SVN-Revision: 23445

include/prereq-build.mk
include/toplevel.mk

index afb92ff..84d3f22 100644 (file)
@@ -18,13 +18,6 @@ $(eval $(call Require,non-root, \
        Please do not compile as root. \
 ))
 
-define Require/umask-0022
-       [ "$$(shell umask)" -eq 22 ]
-endef
-$(eval $(call Require,umask-0022, \
-       Please compile with umask 0022. \
-))
-
 # Required for the toolchain
 define Require/working-make
        $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
index dee43cb..cb50dfa 100644 (file)
@@ -41,6 +41,8 @@ endif
 SCAN_COOKIE?=$(shell echo $$$$)
 export SCAN_COOKIE
 
+SUBMAKE:=umask 022; $(SUBMAKE)
+
 prepare-mk: FORCE ;
 
 prepare-tmpinfo: FORCE