portsentry:
authorOliver Ertl <oliver@ertl-net.net>
Thu, 20 Sep 2007 15:39:43 +0000 (15:39 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Thu, 20 Sep 2007 15:39:43 +0000 (15:39 +0000)
 * Fix linking (#2414), Thanks for reporting!
 * Refresh patches

SVN-Revision: 8877

net/portsentry/Makefile
net/portsentry/patches/100-conf_location.patch
net/portsentry/patches/101-postsentry_c.patch

index e1f77d6f4b5029d1b97cd22e1dac8c5f9f4baa15..d02a9ff4807d1c5318484fdfbad8876f463f58a9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
 PKG_SOURCE_URL:=@SF/sentrytools
 PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
 
@@ -32,12 +31,8 @@ define Package/portsentry/conffiles
 /etc/portsentry.conf
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) linux
-endef
+MAKE_FLAGS += \
+       linux \
 
 define Package/portsentry/install      
        $(INSTALL_DIR) $(1)/etc
index 457c9c827babd3636494f1be5a0ac75d02443322..d6448259bbd86eefc6393616b826f3a35298a5aa 100644 (file)
@@ -1,5 +1,7 @@
---- portsentry/portsentry_config.h     2003-05-23 20:10:13.000000000 +0200
-+++ portsentry.old/portsentry_config.h 2005-07-09 21:21:15.000000000 +0200
+Index: portsentry_beta/portsentry_config.h
+===================================================================
+--- portsentry_beta.orig/portsentry_config.h   2007-09-20 17:30:32.000000000 +0200
++++ portsentry_beta/portsentry_config.h        2007-09-20 17:30:32.000000000 +0200
 @@ -22,7 +22,7 @@
  
  /* These are probably ok. Be sure you change the Makefile if you */
index e36bb2a123baabff9c1a93ce2e15e3882e457500..51374bd08b378afaf7281ab65c8e64c9dc49bcad 100644 (file)
@@ -1,5 +1,7 @@
---- portsentry/portsentry.c    2003-05-23 20:10:13.000000000 +0200
-+++ portsentry.old/portsentry.c        2005-07-09 21:57:24.000000000 +0200
+Index: portsentry_beta/portsentry.c
+===================================================================
+--- portsentry_beta.orig/portsentry.c  2007-09-20 17:30:32.000000000 +0200
++++ portsentry_beta/portsentry.c       2007-09-20 17:30:32.000000000 +0200
 @@ -1581,8 +1581,7 @@
  Usage (void)
  {