[PATCH] yaddns: update to 1.1-rc2
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 09:37:51 +0000 (09:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 09:37:51 +0000 (09:37 +0000)
Hi,

The patch attached to the mail updates yaddns to 1.1-rc2. Changes are:

  * autotools refactoring
  * fix blocked state in request if connect() or recv() failed.
    Add timeout feature which abort pending request (connect(), send(), recv())
    after XX seconds.
  * add new ./configure options:
    * --enable-debug
    * --enable-debug-log
  * fix segfault case if user remove account cfg and SIGHUP yaddns when
    doing update procedure for the removed account.
  * fix buffer overread in base64_encode function
  * implement unit tests

Regards,
Anthony.

SVN-Revision: 26993

net/yaddns/Makefile

index 909f1dda2c8313caa40943ebffcd7cce9b4a02cb..8f55694ffce859a6c1fa75e10a40e30dfc53ffe5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=yaddns
-PKG_VERSION:=1.0-rc3
+PKG_VERSION:=1.1-rc2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.gna.org/yaddns/
-PKG_MD5SUM:=fa1492212a09e0f5f39d3fa65ddf257e
+PKG_MD5SUM:=919a25bd66abf926e049f3afea619e19
 
 PKG_INSTALL:=1