kernel: enable MPPE again, got broken in r26296
authorFelix Fietkau <nbd@openwrt.org>
Thu, 7 Apr 2011 19:06:34 +0000 (19:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 7 Apr 2011 19:06:34 +0000 (19:06 +0000)
Since r26296 mppe.ko could not be loaded, kernel gives "device missing" error.
According to KConfig cypther-ecb is required.

Signed-off-by: Sven Roederer <mailinglists.sven_at_roederer.dhs.org>
SVN-Revision: 26507

package/kernel/modules/netsupport.mk

index 3a1a3b4..8987fe4 100644 (file)
@@ -526,7 +526,7 @@ $(eval $(call KernelPackage,ipoa))
 define KernelPackage/mppe
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Microsoft PPP compression/encryption
-  DEPENDS:=kmod-ppp +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-sha1
+  DEPENDS:=kmod-ppp +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-sha1 +kmod-crypto-ecb
   KCONFIG:= \
        CONFIG_PPP_MPPE_MPPC \
        CONFIG_PPP_MPPE