revert [14081]: iptunnel4 does not make sense on 2.4, just add a conditionnal depende...
authorNicolas Thill <nico@openwrt.org>
Tue, 27 Jan 2009 09:56:05 +0000 (09:56 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 27 Jan 2009 09:56:05 +0000 (09:56 +0000)
SVN-Revision: 14219

package/kernel/modules/netsupport.mk

index 3cc1ebb..add8024 100644 (file)
@@ -118,7 +118,7 @@ $(eval $(call KernelPackage,misdn))
 define KernelPackage/ipip
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IP-in-IP encapsulation
-  DEPENDS:=+kmod-iptunnel4
+  DEPENDS:=+LINUX_2_6:kmod-iptunnel4
   KCONFIG:=CONFIG_NET_IPIP
   FILES:=$(LINUX_DIR)/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,32,ipip)
@@ -216,22 +216,19 @@ endef
 
 $(eval $(call KernelPackage,ipsec6))
 
-define KernelPackage/iptunnel4
-  TITLE:=IP in IP encapsulation support
-  KCONFIG:=$(CONFIG_NET_IPIP)
-  SUBMENU:=$(NSMENU)
-endef
 
-define KernelPackage/iptunnel4/2.4
-  FILES:=$(LINUX_DIR)/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,ipip)
-endef
-
-define KernelPackage/iptunnel4/2.6
-  FILES:= \
-       $(LINUX_DIR)/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/net/ipv4/tunnel4.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,ipip tunnel4)
+# NOTE: tunnel4 is not selectable by itself, so enable ipip for that
+define KernelPackage/iptunnel4
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=IPv4 tunneling
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:= \
+       CONFIG_NET_IPIP \
+       CONFIG_INET_TUNNEL
+  FILES:= $(foreach mod,tunnel4, \
+       $(LINUX_DIR)/net/ipv4/$(mod).$(LINUX_KMOD_SUFFIX) \
+  )
+  AUTOLOAD:=$(call AutoLoad,31,tunnel4)
 endef
 
 define KernelPackage/iptunnel4/description
@@ -240,6 +237,7 @@ endef
 
 $(eval $(call KernelPackage,iptunnel4))
 
+
 define KernelPackage/iptunnel6
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv6 tunneling