[package] kernel: add kmod-acpi-button
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Mar 2012 23:48:38 +0000 (23:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Mar 2012 23:48:38 +0000 (23:48 +0000)
SVN-Revision: 31037

package/kernel/modules/other.mk

index b57d055d361cc23039e130d27f2d84c15227fbf6..69c7a78fcb0a128c03f0f734e49eb2ef9e7c6ea8 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -890,3 +890,18 @@ endef
 
 $(eval $(call KernelPackage,serial-8250))
 
 
 $(eval $(call KernelPackage,serial-8250))
 
+
+define KernelPackage/acpi-button
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=ACPI Button Support
+  DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
+  KCONFIG:=CONFIG_ACPI_BUTTON
+  FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
+  AUTOLOAD:=$(call AutoLoad,06,button)
+endef
+
+define KernelPackage/acpi-button/description
+ Kernel module for ACPI Button support
+endef
+
+$(eval $(call KernelPackage,acpi-button))