Added igmpproxy, an IGMP daemon
authorFlorian Fainelli <florian@openwrt.org>
Thu, 2 Mar 2006 11:28:08 +0000 (11:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 2 Mar 2006 11:28:08 +0000 (11:28 +0000)
SVN-Revision: 3295

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/igmpproxy/Config.in [new file with mode: 0644]
openwrt/package/igmpproxy/Makefile [new file with mode: 0644]
openwrt/package/igmpproxy/ipkg/igmpproxy.control [new file with mode: 0644]

index 3266ed98e551379b788f7ff2da0eb9b2d5e66e57..3fd24e8ccd031813f26dd594aa171a2612dc94c8 100644 (file)
@@ -80,6 +80,7 @@ source "package/hostapd/Config.in"
 source "package/htpdate/Config.in"
 source "package/httping/Config.in"
 source "package/iftop/Config.in"
 source "package/htpdate/Config.in"
 source "package/httping/Config.in"
 source "package/iftop/Config.in"
+source "package/igmpproxy/Config.in"
 source "package/ipcad/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
 source "package/ipcad/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
index fab053b68069d8b6edd5be32c92e0444be2652dc..42c6f507045a7eac2de01463d1659894d3ddb656 100644 (file)
@@ -68,6 +68,7 @@ package-$(BR2_PACKAGE_HTTPING) += httping
 package-$(BR2_PACKAGE_ICECAST) += icecast
 package-$(BR2_PACKAGE_ID3LIB) += id3lib
 package-$(BR2_PACKAGE_IFTOP) += iftop
 package-$(BR2_PACKAGE_ICECAST) += icecast
 package-$(BR2_PACKAGE_ID3LIB) += id3lib
 package-$(BR2_PACKAGE_IFTOP) += iftop
+package-$(BR2_PACKAGE_IGMPPROXY) += igmpproxy
 package-$(BR2_PACKAGE_IPCAD) += ipcad
 package-$(BR2_PACKAGE_IPERF) += iperf
 package-$(BR2_PACKAGE_IPKG) += ipkg
 package-$(BR2_PACKAGE_IPCAD) += ipcad
 package-$(BR2_PACKAGE_IPERF) += iperf
 package-$(BR2_PACKAGE_IPKG) += ipkg
diff --git a/openwrt/package/igmpproxy/Config.in b/openwrt/package/igmpproxy/Config.in
new file mode 100644 (file)
index 0000000..c66258a
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_IGMPPROXY
+       prompt "igmpproxy......................... Multicast Routing Daemon"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         IGMPproxy is a simple dynamic Multicast Routing Daemon using 
+         only IGMP signalling (Internet Group Management Protocol).
+
+         http://sourceforge.net/projects/igmpproxy
diff --git a/openwrt/package/igmpproxy/Makefile b/openwrt/package/igmpproxy/Makefile
new file mode 100644 (file)
index 0000000..ef144e0
--- /dev/null
@@ -0,0 +1,31 @@
+# $Id: Makefile 1084 2005-05-27 17:32:43Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=igmpproxy
+PKG_VERSION:=0.1-beta2
+PKG_RELEASE:=1
+PKG_MD5SUM:=2a5a59480f44d4b14077a6b5319e9940
+
+PKG_SOURCE_URL:=@SF/igmpproxy
+PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_CAT:=zcat
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IGMPPROXY,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/src
+       touch $@
+
+$(IPKG_IGMPPROXY):
+       mkdir -p $(IDIR_IGMPPROXY)/usr/sbin $(IDIR_IGMPPROXY)/etc
+       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(IDIR_IGMPPROXY)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME).conf $(IDIR_IGMPPROXY)/etc
+       $(STRIP) $(IDIR_IGMPPROXY)/usr/sbin/*
+       $(IPKG_BUILD) $(IDIR_IGMPPROXY) $(PACKAGE_DIR)
diff --git a/openwrt/package/igmpproxy/ipkg/igmpproxy.control b/openwrt/package/igmpproxy/ipkg/igmpproxy.control
new file mode 100644 (file)
index 0000000..26bfe15
--- /dev/null
@@ -0,0 +1,4 @@
+Package: igmpproxy
+Section: net
+Priority: optional
+Description: IGMPproxy is a simple dynamic Multicast Routing Daemon.