brcm63xx: move gzip build command to include/image.mk
authorJonas Gorski <jogo@openwrt.org>
Fri, 14 Aug 2015 15:10:47 +0000 (15:10 +0000)
committerJonas Gorski <jogo@openwrt.org>
Fri, 14 Aug 2015 15:10:47 +0000 (15:10 +0000)
Allow other targets to make use of it.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46601

include/image.mk
target/linux/brcm63xx/image/Makefile

index 56c60d608743ab0d9c8216c321c533463207e25c..73fc805bb589da9c9b9a270f3a12dc7524e193dd 100644 (file)
@@ -323,6 +323,11 @@ define Build/lzma
        @mv $@.new $@
 endef
 
+define Build/gzip
+       gzip -9n -c $@ $(1) > $@.new
+       @mv $@.new $@
+endef
+
 define Build/kernel-bin
        rm -f $@
        cp $^ $@
index f15b30b5f1b183bf1c75683a622a6b5cb277066e..90b9fa68eb4ba1b5903132e50df3e583b18bec04 100755 (executable)
@@ -38,11 +38,6 @@ define Build/append-dtb
        cat $@.dtb >> $@
 endef
 
-define Build/gzip
-       gzip -9 -c $@ > $@.gz
-       mv $@.gz $@
-endef
-
 define Build/hcs-initramfs
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_bytes=$(HCS_MAGIC_BYTES) \
                --rev_maj=$(HCS_REV_MAJ) --rev_min=$(HCS_REV_MIN) --input_file=$@ \