[packages] miniupnpd: append netmask to listening_ip, fixes miniupnpd with non-/24...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 7 Jan 2012 13:32:30 +0000 (13:32 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 7 Jan 2012 13:32:30 +0000 (13:32 +0000)
SVN-Revision: 29673

net/miniupnpd/Makefile
net/miniupnpd/files/miniupnpd.init

index d11ea8ff9f92f3074477966d3ae81e25faab7d4b..ca0dfaaf589f9e13dfc84354d3cda3b66378dc4f 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.6.20110730
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index fa888dde43567fc3d1adbae88839bd62d1600f73..c29e67254ae700b9eae12597757806116efc2f5a 100644 (file)
@@ -106,10 +106,11 @@ start() {
 
                local iface
                for iface in ${intiface:-lan}; do
-                       local ipaddr
+                       local ipaddr netmask
                        config_get ipaddr "$iface" ipaddr
+                       config_get netmask "$iface" netmask "255.255.255.0"
                        [ -n "$ipaddr" ] && \
-                               echo "listening_ip=$ipaddr" >>$tmpconf
+                               echo "listening_ip=$ipaddr/$netmask" >>$tmpconf
                done
 
                [ "$port" != "auto" ] && \