since uclibc version 0.9.32 comes with nptl support, packages requiring nptl support...
authorMirko Vogt <mirko@openwrt.org>
Tue, 22 Jun 2010 10:04:20 +0000 (10:04 +0000)
committerMirko Vogt <mirko@openwrt.org>
Tue, 22 Jun 2010 10:04:20 +0000 (10:04 +0000)
SVN-Revision: 21873

Xorg/lib/qt4/Makefile

index 0bae711..0b487ef 100644 (file)
@@ -104,13 +104,13 @@ endef
 define Package/qt4-webkit
   $(call Package/qt4/Default)
   TITLE+=(webkit)
 define Package/qt4-webkit
   $(call Package/qt4/Default)
   TITLE+=(webkit)
-  DEPENDS+=@USE_GLIBC||@USE_EGLIBC # until we do not have nptl-support within uclibc javascriptcore will fail to link against uclibc
+  DEPENDS+=@USE_GLIBC||@USE_EGLIBC||@UCLIBC_VERSION_0_9_32 # versions of uclibc prior 0.9.32 do not have nptl support
 endef
 
 define Package/qt4-script
   $(call Package/qt4/Default)
   TITLE+=(script)
 endef
 
 define Package/qt4-script
   $(call Package/qt4/Default)
   TITLE+=(script)
-  DEPENDS+=@USE_GLIBC||@USE_EGLIBC # until we do not have nptl-support within uclibc, javascriptcore will fail to link against uclibc
+  DEPENDS+=@USE_GLIBC||@USE_EGLIBC||@UCLIBC_VERSION_0_9_32 # versions of uclibc prior 0.9.32 do not have nptl support
 endef
 
 define Package/qt4-scripttools
 endef
 
 define Package/qt4-scripttools