[packages] apr: ditch shipped libtool, make it non-silent
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 5 May 2011 14:40:50 +0000 (14:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 5 May 2011 14:40:50 +0000 (14:40 +0000)
SVN-Revision: 26831

libs/apr/Makefile
libs/apr/patches/001-autoconf-compat.patch

index 94bfd995d809972523f1b352afb8285f53ef516f..4a0b704762e0032c418a224d66951ee4c59b1f93 100644 (file)
@@ -15,7 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
 PKG_MD5SUM:=4b00e8f70c067893d075577962656b35
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=aclocal.m4 build/ltmain.sh
 
 PKG_INSTALL:=1
 
index 0f383eb480b918e2f4ca75ba6feefe3ba72bc219..88f71fd6b83d87b54d1cc8a3ed51cc634827df0e 100644 (file)
@@ -8,3 +8,15 @@
  
  #
  # APR (Apache Portable Runtime) library Makefile.
+--- a/configure.in
++++ b/configure.in
+@@ -180,9 +180,6 @@ case $host in
+     gcc $CFLAGS $CPPFLAGS -o $LIBTOOL.exe $LIBTOOL.c
+     ;;
+ *)
+-    if test "x$LTFLAGS" = "x"; then
+-        LTFLAGS='--silent'
+-    fi
+     if test "$experimental_libtool" = "yes"; then
+         # Use a custom-made libtool replacement
+         echo "using jlibtool"