[packages] shadow: force full autoreconf
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Dec 2010 17:15:32 +0000 (17:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Dec 2010 17:15:32 +0000 (17:15 +0000)
SVN-Revision: 24393

utils/shadow/Makefile

index 2a4ae49fd9886acd08e87879b4f660daf7e9940d..ae0846d295ad19ae8fe7a4ca8e31c7514a9537f5 100644 (file)
@@ -15,6 +15,9 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.pld-linux.org/software/shadow
 PKG_MD5SUM:=4fa404ebb4e29828232b3c9a2abddefd
 
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=aclocal.m4 ltmain.sh
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -40,6 +43,11 @@ define Package/shadow/install
        true
 endef
 
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); autoreconf --force --install)
+       $(call Build/Configure/Default)
+endef
+
 
 define program
   define Package/shadow-$(1)