update radiusclient-ng to 0.5.6 (closes: #3589), fix package descriptions and formatting
authorNicolas Thill <nico@openwrt.org>
Tue, 29 Jul 2008 23:36:10 +0000 (23:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 29 Jul 2008 23:36:10 +0000 (23:36 +0000)
SVN-Revision: 11997

libs/radiusclient-ng/Makefile
libs/radiusclient-ng/patches/001-cross_compile.patch

index 52449ffb11c7f4345f6a2df3d7a36c21ee2284ab..06aa5fb7e99e1882b79460c512dabbe988b1d5ad 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radiusclient-ng
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radiusclient-ng
-PKG_VERSION:=0.5.2
+PKG_VERSION:=0.5.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/radiusclient-ng/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/radiusclient-ng/
-PKG_MD5SUM:=c54eb70e964bdd22dd44b39a9b4df8ca
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=6fb7d4d0aefafaee7385831ac46a8e9c
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,19 +22,22 @@ define Package/radiusclient-ng/Default
   URL:=http://developer.berlios.de/projects/radiusclient-ng/
 endef
   
   URL:=http://developer.berlios.de/projects/radiusclient-ng/
 endef
   
+define Package/radiusclient-ng/Default/description
+ Purpose of this project is to build a portable, easy-to-use and 
+ standard compliant library suitable for developing free and commercial 
+ software that need support for RADIUS protocol (RFCs 2128 and 2139).
+endef
+
 define Package/libradiusclient-ng
 define Package/libradiusclient-ng
-  $(call Package/radiusclient-ng/Default)
+$(call Package/radiusclient-ng/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=RADIUS client library
 endef
 
 define Package/libradiusclient-ng/description
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=RADIUS client library
 endef
 
 define Package/libradiusclient-ng/description
-=
-       Purpose of this project is to build a portable, easy-to-use and standard 
-       compliant library suitable for developing free and commercial software 
-       that need support for RADIUS protocol (RFCs 2128 and 2139).     
-       This package contains shared libraries, needed by other programs.
+$(call Package/radiusclient-ng/Default/description)
+ This package contains shared libraries, needed by other programs.
 endef
 
 define Package/libradiusclient-ng/conffiles
 endef
 
 define Package/libradiusclient-ng/conffiles
@@ -56,19 +56,13 @@ define Package/radiusclient-ng
 endef
 
 define Package/radiusclient-ng/description
 endef
 
 define Package/radiusclient-ng/description
-=
-       Purpose of this project is to build a portable, easy-to-use and standard 
-       compliant library suitable for developing free and commercial software 
-       that need support for RADIUS protocol (RFCs 2128 and 2139).     
-       This package contains a RADIUS client.
+$(call Package/radiusclient-ng/Default/description)
+ This package contains a RADIUS client.
 endef
 
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
index fa45afb12d872773f9268fac0bfed6c399985daa..fc4d21ddca5f36228f0dfdfeb398b692352eeeb7 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN radiusclient-ng-0.5.2/configure radiusclient-ng-0.5.2.new/configure
---- radiusclient-ng-0.5.2/configure    2005-11-07 22:18:59.000000000 +0100
-+++ radiusclient-ng-0.5.2.new/configure        2006-03-10 01:51:59.489383320 +0100
-@@ -23791,8 +23791,7 @@
+--- radiusclient-ng-0.5.6.orig/configure
++++ radiusclient-ng-0.5.6/configure
+@@ -23332,8 +23332,7 @@
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
@@ -11,19 +10,3 @@ diff -urN radiusclient-ng-0.5.2/configure radiusclient-ng-0.5.2.new/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-diff -urN radiusclient-ng-0.5.2/etc/Makefile.in radiusclient-ng-0.5.2.new/etc/Makefile.in
---- radiusclient-ng-0.5.2/etc/Makefile.in      2005-11-08 00:15:35.000000000 +0100
-+++ radiusclient-ng-0.5.2.new/etc/Makefile.in  2006-03-10 01:58:29.345116240 +0100
-@@ -376,9 +376,9 @@
-           <$(srcdir)/radiusclient.conf.in >radiusclient.conf
- install-data-local: servers
--      $(mkinstalldirs) $(pkgsysconfdir); \
--        echo " $(INSTALL) -m 600 $(srcdir)/servers $(pkgsysconfdir)/servers"; \
--        $(INSTALL) -m 600 $(srcdir)/servers $(pkgsysconfdir)/servers
-+      $(mkinstalldirs) $(DESTDIR)/$(pkgsysconfdir); \
-+        echo " $(INSTALL) -m 600 $(srcdir)/servers $(DESTDIR)/$(pkgsysconfdir)/servers"; \
-+        $(INSTALL) -m 600 $(srcdir)/servers $(DESTDIR)/$(pkgsysconfdir)/servers
- uninstall-local:
-       rm -f $(pkgsysconfdir)/servers