add kernel module for PCengines WRAP leds
authorNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 19:31:37 +0000 (19:31 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 19:31:37 +0000 (19:31 +0000)
SVN-Revision: 8814

package/kernel/modules/other.mk

index 352bfb0012300648e70c66309447c3b6bd26feed..a6897d8eb6c548d3843d82b8735201b1b4e299a5 100644 (file)
@@ -387,6 +387,22 @@ endef
 $(eval $(call KernelPackage,leds-net48xx))
 
 
+define KernelPackage/leds-wrap
+  SUBMENU:=$(EMENU)
+  TITLE:=PCengines WRAP LED support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_LEDS_WRAP
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
 define KernelPackage/nsc-gpio
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Natsemi GPIO support