Click should be built with -Os, not -O2
authorFlorian Fainelli <florian@openwrt.org>
Thu, 19 Jul 2007 12:31:02 +0000 (12:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 19 Jul 2007 12:31:02 +0000 (12:31 +0000)
SVN-Revision: 8053

net/click/Makefile

index dae1f1c354cf10d4297d9f53367259fed16df72f..f3851236f53436ff4cb22b7b18f99099eb9f4384 100644 (file)
@@ -55,7 +55,7 @@ define Build/Configure
                $(CP) include include-host; \
                rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                $(CP) include include-host; \
                rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CXXFLAGS="-static -O2 -MD" \
+               CXXFLAGS="-static -Os -MD" \
                CFLAGS="-static -MD" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                CFLAGS="-static -MD" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \