change bool in BR2_COMPILE_* to tristate to avoid unnecessary package/<foo>-install...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 7 Nov 2005 18:26:35 +0000 (18:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 7 Nov 2005 18:26:35 +0000 (18:26 +0000)
SVN-Revision: 2388

59 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/atftp/Config.in
openwrt/package/avahi/Config.in
openwrt/package/bind/Config.in
openwrt/package/curl/Config.in
openwrt/package/cyrus-sasl/Config.in
openwrt/package/dhcp/Config.in
openwrt/package/expat/Config.in
openwrt/package/flac/Config.in
openwrt/package/fuse/Config.in
openwrt/package/glib/Config.in
openwrt/package/gmp/Config.in
openwrt/package/gnutls/Config.in
openwrt/package/howl/Config.in
openwrt/package/iproute2/Config.in
openwrt/package/jpeg/Config.in
openwrt/package/kismet/Config.in
openwrt/package/libdb/Config.in
openwrt/package/liblzo/Config.in [new file with mode: 0644]
openwrt/package/liblzo/Makefile [new file with mode: 0644]
openwrt/package/liblzo/ipkg/liblzo.control [new file with mode: 0644]
openwrt/package/liblzo/patches/lzo-cross-compile.patch [new file with mode: 0644]
openwrt/package/libtool/Config.in
openwrt/package/lua/Config.in
openwrt/package/lzo/Config.in [deleted file]
openwrt/package/lzo/Makefile [deleted file]
openwrt/package/lzo/ipkg/liblzo.control [deleted file]
openwrt/package/lzo/patches/lzo-cross-compile.patch [deleted file]
openwrt/package/matrixssl/Config.in
openwrt/package/mini_httpd/Config.in
openwrt/package/miredo/Config.in
openwrt/package/monit/Config.in
openwrt/package/mysql/Config.in
openwrt/package/ncurses/Config.in
openwrt/package/ndisc/Config.in
openwrt/package/net-snmp/Config.in
openwrt/package/opencdk/Config.in
openwrt/package/openldap/Config.in
openwrt/package/openssh/Config.in
openwrt/package/openssl/Config.in
openwrt/package/osiris/Config.in
openwrt/package/pcre/Config.in
openwrt/package/php4/Config.in
openwrt/package/php5/Config.in
openwrt/package/popt/Config.in
openwrt/package/postgresql/Config.in
openwrt/package/readline/Config.in
openwrt/package/rp-pppoe/Config.in
openwrt/package/rrdtool1/Config.in
openwrt/package/rrs/Config.in
openwrt/package/sablevm-classpath/Config.in
openwrt/package/samba/Config.in
openwrt/package/shfs/Config.in
openwrt/package/speex/Config.in
openwrt/package/sqlite/Config.in
openwrt/package/sqlite2/Config.in
openwrt/package/usbutils/Config.in
openwrt/package/util-linux/Config.in

index 8cf05585ad6dd45cef1535cdeb90b4fac655ab07..730b819d5b02c5688cb05b8e0705a260f5974d01 100644 (file)
@@ -171,7 +171,7 @@ source "package/libgpg-error/Config.in"
 source "package/libid3tag/Config.in"
 source "package/jpeg/Config.in"  # libjpeg
 source "package/libtool/Config.in"  # libltdl
-source "package/lzo/Config.in"  # liblzo
+source "package/liblzo/Config.in"
 source "package/libmad/Config.in"
 source "package/matrixssl/Config.in"  # libmatrixssl
 source "package/mysql/Config.in"  # limysqlclient
index ff6bc640fa16d246ce64c2842e6bba26e2911f26..3f53d732376021d26f042eba166695e898015e47 100644 (file)
@@ -83,6 +83,7 @@ package-$(BR2_PACKAGE_LIBGD) += libgd
 package-$(BR2_PACKAGE_LIBGDBM) += libgdbm
 package-$(BR2_PACKAGE_LIBGPG_ERROR) += libgpg-error
 package-$(BR2_PACKAGE_LIBID3TAG) += libid3tag
+package-$(BR2_PACKAGE_LIBLZO) += liblzo
 package-$(BR2_PACKAGE_LIBMAD) += libmad
 package-$(BR2_PACKAGE_LIBNET) += libnet
 package-$(BR2_PACKAGE_LIBNIDS) += libnids
@@ -102,7 +103,6 @@ package-$(BR2_PACKAGE_LIBXSLT) += libxslt
 package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
 package-$(BR2_COMPILE_LUA) += lua
-package-$(BR2_COMPILE_LZO) += lzo
 package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
@@ -212,7 +212,7 @@ package-$(BR2_PACKAGE_XINETD) += xinetd
 package-$(BR2_PACKAGE_XSUPPLICANT) += xsupplicant
 package-$(BR2_PACKAGE_ZLIB) += zlib
 
-DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm libamsel libao libart libdaemon libdb libdnet libevent libffi-sable libgcrypt libgdbm libgpg-error libid3tag libmad libnet libnids libogg libosip2 libpcap libtasn1 libupnp libusb libvorbis libvorbisidec libxml2 libxslt id3lib
+DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl liblzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm libamsel libao libart libdaemon libdb libdnet libevent libffi-sable libgcrypt libgdbm libgpg-error libid3tag libmad libnet libnids libogg libosip2 libpcap libtasn1 libupnp libusb libvorbis libvorbisidec libxml2 libxslt id3lib
 DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
 SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge ipkg ppp
 SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
@@ -297,10 +297,10 @@ socat-compile: openssl-compile
 sqlite-compile: ncurses-compile readline-compile
 sqlite2-compile: ncurses-compile readline-compile
 tcpdump-compile: libpcap-compile
-tinc-compile: zlib-compile openssl-compile lzo-compile
+tinc-compile: zlib-compile openssl-compile liblzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
 usbutils-compile: libusb-compile
-vtun-compile: zlib-compile openssl-compile lzo-compile
+vtun-compile: zlib-compile openssl-compile liblzo-compile
 wificonf-compile: wireless-tools-compile nvram-compile
 wknock-compile: libpcap-compile
 wpa_supplicant-compile: openssl-compile
@@ -347,7 +347,7 @@ endif
 
 openvpn-compile: openssl-compile
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
-openvpn-compile: lzo-compile
+openvpn-compile: liblzo-compile
 endif
 
 php4-compile: openssl-compile zlib-compile
index c84e316cb9dd84d9d847e5d83b121082e50193a7..32ab9512a38c8697f33a9d1dded00fc5d64a783c 100644 (file)
@@ -1,7 +1,7 @@
 #menu "atftp............................. TFTP implementation"
 
 config BR2_COMPILE_ATFTP
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_ATFTP || BR2_PACKAGE_ATFTPD
        
index 1f2804c62a3716f7bed591eef09d096a4570f236..69461a58ea7abe3865a32585e5a612d8a55fe5d4 100644 (file)
@@ -1,7 +1,7 @@
 menu "avahi............................. An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation"
 
 config BR2_COMPILE_AVAHI
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_AVAHI_DAEMON || BR2_PACKAGE_AVAHI_DNSCONFD || BR2_PACKAGE_LIBAVAHI
 
index 1acb5857e908ba10188380e6a6ad87c9def3bd0d..38dc92f6f44fc64a4fdf3b32bb265953a59b451c 100644 (file)
@@ -1,7 +1,7 @@
 #menu "bind.............................. A DNS server implementation"
 
 config BR2_COMPILE_BIND
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_BIND_CLIENT || BR2_PACKAGE_BIND_SERVER
        
index f3bf79f40cd2540a36dba22ed337e8ea4ad1bf63..9f8768c3bd0c17cda915c14260cd7badcf6c7dd1 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_CURL
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBCURL
 
index de3c3d3fb533bc64004ea13b30b8bd5d39424aa9..599a87c5dbcb244234a972a035c094a5cfa158dd 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_CYRUS_SASL
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBSASL2
 
index 5449c207b97e433a58b5aaf2842c77915760fb6e..f29beeeda05114f98a32c60f6ad96cd4bd574f1a 100644 (file)
@@ -1,7 +1,7 @@
 #menu "dhcp.............................. ISC DHCP (Dynamic Host Configuration Protocol) implementation"
 
 config BR2_COMPILE_DHCP
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_DHCP_RELAY || BR2_PACKAGE_DHCP_SERVER
 
index 0347f3bca5f1deccf489ed0c3b8198f03e00cf55..9b34c52c897be2754b9daf96d365d27db91c5af1 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_EXPAT
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBEXPAT
 
index 12405fc3995906ce0cc55d6d7b3ff14f1ccce261..87f88a38344668a60fd32117bee5aa88198aa1d7 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_FLAC
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBFLAC
 
index d24598619ae54eec235b816b95e542a25da0f331..2d8b1775a0294ad498a9359b881ac74c7496a95d 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_FUSE
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBFUSE
 
index 1ec23b9ef76e8d9d7f4a6251e8c564b3452d51ac..f11c06370f357e923f77513005a411a43c82f266 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_GLIB
-       bool
+       tristate
        depends BR2_PACKAGE_GLIB1
 
 config BR2_PACKAGE_GLIB1
index f00ee92262f0e7ec8048f8dcf33397d154ca2723..1e995a7340c45a317f3495e432b7c5b0d9247e14 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_GMP
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBGMP
 
index 291084f1ab13c2c350d4565c88f78902b7f1f66e..bb3ea99e7baf891e2b7399767e27e3da57f66590 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_GNUTLS
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBGNUTLS
 
index a55bbf35f4509edb81fff6f44aa9e32c11f289c5..a409dd2a641b995f23a7fd6d9f58646e539ad4af 100644 (file)
@@ -1,7 +1,7 @@
 menu "howl.............................. A Zeroconf networking implementation"
 
 config BR2_COMPILE_HOWL
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBHOWL
 
index 85fa18421a587f62137f4f5c5d3fc9ea4b737beb..349e3b7df2f993ee7c40d8894cefb10e30e68228 100644 (file)
@@ -1,7 +1,7 @@
 menu "iproute2.......................... A collection of utilites for controlling TCP/IP networking and Traffic Control"
 
 config BR2_COMPILE_IPROUTE2
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_IPROUTE2_IP || BR2_PACKAGE_IPROUTE2_TC
 
index f493183357d1db5fc06be753d56c2d8f72024623..326fa8b5f4d65e4410502955bf4b5d9e2efa1e9c 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_JPEG
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBJPEG
 
index 6a5fbebd70ab5d22ef9baaa7607220ebbe1a1636..425ec6c511aae01ebf0202cbeac0530477cbbb8c 100644 (file)
@@ -1,7 +1,7 @@
 #menu "kismet............................ An 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
 
 config BR2_COMPILE_KISMET
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_KISMET_CLIENT || BR2_PACKAGE_KISMET_DRONE || BR2_PACKAGE_KISMET_SERVER
 
index 2a7b771258ab00b9da82ea303d5716f5a836de74..5871032a8a366df4d7ccfebf9614221ffe0f8191 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_DB
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBDB
 
diff --git a/openwrt/package/liblzo/Config.in b/openwrt/package/liblzo/Config.in
new file mode 100644 (file)
index 0000000..b63a09a
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBLZO
+       prompt "liblzo............................ Real-time data compression library"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         A real-time data compression library
+         
+         http://www.oberhumer.com/opensource/lzo/
+
diff --git a/openwrt/package/liblzo/Makefile b/openwrt/package/liblzo/Makefile
new file mode 100644 (file)
index 0000000..dddc3ce
--- /dev/null
@@ -0,0 +1,82 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lzo
+PKG_VERSION:=1.08
+PKG_RELEASE:=1
+PKG_MD5SUM:=ab94d3da364c7cbd5b78d76f1875b0f6
+
+PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBLZO,liblzo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: 
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(strip $(TARGET_CFLAGS))" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --enable-static \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CFLAGS_O="$(TARGET_CFLAGS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_LIBLZO):
+       install -d -m0755 $(IDIR_LIBLZO)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/liblzo.so.* $(IDIR_LIBLZO)/usr/lib
+       $(RSTRIP) $(IDIR_LIBLZO)
+       $(IPKG_BUILD) $(IDIR_LIBLZO) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/liblzo.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/lzo*.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/liblzo.{a,so*} $(STAGING_DIR)/usr/lib/
+       touch $(STAGING_DIR)/usr/lib/liblzo.so
+
+install-dev: $(STAGING_DIR)/usr/lib/liblzo.so
+
+uninstall-dev:
+       rm -rf \
+         $(STAGING_DIR)/usr/include/lzo*.h \
+         $(STAGING_DIR)/usr/lib/liblzo.{a,so*} \
+
+compile-targets: install-dev
+clean-targets: uninstall-dev
diff --git a/openwrt/package/liblzo/ipkg/liblzo.control b/openwrt/package/liblzo/ipkg/liblzo.control
new file mode 100644 (file)
index 0000000..3f84ee6
--- /dev/null
@@ -0,0 +1,4 @@
+Package: liblzo
+Priority: optional
+Section: libs
+Description: a real-time data compression library
diff --git a/openwrt/package/liblzo/patches/lzo-cross-compile.patch b/openwrt/package/liblzo/patches/lzo-cross-compile.patch
new file mode 100644 (file)
index 0000000..68a3d04
--- /dev/null
@@ -0,0 +1,43 @@
+For some reason the lzo autoconf script uses a local macro that does
+a test for cross-compiles, and assumes that if the build target name
+and the host target name are the same that --host was not specified to
+the configure script. In the uClibc buildroot, this is not the case.
+
+--- lzo-1.08/aclocal.m4        2002-07-12 18:31:52.000000000 -0700
++++ lzo-1.08/aclocal.m4.new    2004-03-10 15:32:42.000000000 -0700
+@@ -205,12 +205,6 @@
+ [
+ AC_REQUIRE([AC_PROG_CC])
+-if test "X$cross_compiling" = Xyes; then
+-  if test "X$build" = "X$host"; then
+-    AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
+-  fi
+-fi
+-
+ ])
+--- lzo-1.08/configure-dist    2004-03-11 02:18:28.000000000 -0600
++++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
+@@ -2282,13 +2282,13 @@
+-if test "X$cross_compiling" = Xyes; then
+-  if test "X$build" = "X$host"; then
+-    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
+-echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
+-   { (exit 1); exit 1; }; }
+-  fi
+-fi
++#if test "X$cross_compiling" = Xyes; then
++#  if test "X$build" = "X$host"; then
++#    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
++#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
++#   { (exit 1); exit 1; }; }
++#  fi
++#fi
index 5102863a3495b37066ac318767c3ba3e4313ab50..4cc721379b903a558f8f2c851e4a83172b403fa8 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_LIBTOOL
-       bool
+       tristate
        depends BR2_PACKAGE_LIBLTDL
 
 config BR2_PACKAGE_LIBLTDL
index 0b2e850badd4c5bba720e2163fe90c12da144c86..54c633088c5a2ba5f9b9e3deb4256b2fe6e2e36f 100644 (file)
@@ -1,7 +1,7 @@
 menu "lua............................... LUA programming language"
 
 config BR2_COMPILE_LUA
-       bool
+       tristate
        default y
        depends BR2_PACKAGE_LIBLUA
 
diff --git a/openwrt/package/lzo/Config.in b/openwrt/package/lzo/Config.in
deleted file mode 100644 (file)
index 58000d9..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-config BR2_COMPILE_LZO
-       bool
-       default n
-       depends BR2_PACKAGE_LIBLZO
-
-config BR2_PACKAGE_LIBLZO
-       prompt "liblzo............................ Real-time data compression library"
-       tristate
-       default m if CONFIG_DEVEL
-       select BR2_COMPILE_LZO
-       help
-         A real-time data compression library
-         
-         http://www.oberhumer.com/opensource/lzo/
-
diff --git a/openwrt/package/lzo/Makefile b/openwrt/package/lzo/Makefile
deleted file mode 100644 (file)
index dddc3ce..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=lzo
-PKG_VERSION:=1.08
-PKG_RELEASE:=1
-PKG_MD5SUM:=ab94d3da364c7cbd5b78d76f1875b0f6
-
-PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBLZO,liblzo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured: 
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --enable-static \
-       );
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS_O="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-       touch $@
-
-$(IPKG_LIBLZO):
-       install -d -m0755 $(IDIR_LIBLZO)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/liblzo.so.* $(IDIR_LIBLZO)/usr/lib
-       $(RSTRIP) $(IDIR_LIBLZO)
-       $(IPKG_BUILD) $(IDIR_LIBLZO) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/liblzo.so: $(PKG_BUILD_DIR)/.built
-       mkdir -p $(STAGING_DIR)/usr/include
-       cp -fpR $(PKG_INSTALL_DIR)/usr/include/lzo*.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/liblzo.{a,so*} $(STAGING_DIR)/usr/lib/
-       touch $(STAGING_DIR)/usr/lib/liblzo.so
-
-install-dev: $(STAGING_DIR)/usr/lib/liblzo.so
-
-uninstall-dev:
-       rm -rf \
-         $(STAGING_DIR)/usr/include/lzo*.h \
-         $(STAGING_DIR)/usr/lib/liblzo.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/lzo/ipkg/liblzo.control b/openwrt/package/lzo/ipkg/liblzo.control
deleted file mode 100644 (file)
index 3f84ee6..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: liblzo
-Priority: optional
-Section: libs
-Description: a real-time data compression library
diff --git a/openwrt/package/lzo/patches/lzo-cross-compile.patch b/openwrt/package/lzo/patches/lzo-cross-compile.patch
deleted file mode 100644 (file)
index 68a3d04..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-For some reason the lzo autoconf script uses a local macro that does
-a test for cross-compiles, and assumes that if the build target name
-and the host target name are the same that --host was not specified to
-the configure script. In the uClibc buildroot, this is not the case.
-
---- lzo-1.08/aclocal.m4        2002-07-12 18:31:52.000000000 -0700
-+++ lzo-1.08/aclocal.m4.new    2004-03-10 15:32:42.000000000 -0700
-@@ -205,12 +205,6 @@
- [
- AC_REQUIRE([AC_PROG_CC])
--if test "X$cross_compiling" = Xyes; then
--  if test "X$build" = "X$host"; then
--    AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
--  fi
--fi
--
- ])
---- lzo-1.08/configure-dist    2004-03-11 02:18:28.000000000 -0600
-+++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
-@@ -2282,13 +2282,13 @@
--if test "X$cross_compiling" = Xyes; then
--  if test "X$build" = "X$host"; then
--    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
--echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
--   { (exit 1); exit 1; }; }
--  fi
--fi
-+#if test "X$cross_compiling" = Xyes; then
-+#  if test "X$build" = "X$host"; then
-+#    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
-+#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
-+#   { (exit 1); exit 1; }; }
-+#  fi
-+#fi
index be0a306fb39e833a7904acf5bb9bcf7a4111f4f1..3d4532e52a620771fa9be3b22e2f1e3f664b420d 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_MATRIXSSL
-       bool
+       tristate
        depends BR2_PACKAGE_LIBMATRIXSSL
 
 config BR2_PACKAGE_LIBMATRIXSSL
index 2273499fb2dd70e7db1b326652700161dd77f25d..7b908815e0e81605426951f7a85a21829bb397f1 100644 (file)
@@ -1,7 +1,7 @@
 menu "mini-httpd........................ A small web server"
 
 config BR2_COMPILE_MINI_HTTPD
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_MINI_HTTPD || BR2_PACKAGE_MINI_HTTPD_MATRIXSSL || BR2_PACKAGE_MINI_HTTPD_OPENSSL
 
index d07dd8162301f1d6736e944540e43a03d2befe23..eadca0a6e5d2c708325cb576bf3be47a59fd8265 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_MIREDO
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_MIREDO || BR2_PACKAGE_MIREDO_SERVER
 
index e07fd628be65c89a1b2bd1ae8d7a970da91ad971..d8221ef59c1a3cff6a087c23fa25ed3ca18a0440 100644 (file)
@@ -1,7 +1,7 @@
 #menu "monit............................. System services monitoring utility"
 
 config BR2_COMPILE_MONIT
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_MONIT || BR2_PACKAGE_MONIT_NOSSL
 
index 89f0e264896c7f93bb4e114243813cbef6123cb3..bda7142ca94da54c9077bdffbfd6b931fa528ae4 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_MYSQL
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBMYSQLCLIENT
 
index 1fbdd7b3f48d13ed0ad4aed6aa45ad913ba402be..552a6ccd28071a4b15d078ff5d24f14643621002 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_NCURSES
-       bool
+       tristate
        depends BR2_PACKAGE_LIBNCURSES
 
 config BR2_PACKAGE_LIBNCURSES
index a1ae2dc6d1b6e16be4043116a9423f1c019f8ef3..5513edb0a61b8e0607feec81993301b05f270b2c 100644 (file)
@@ -1,7 +1,7 @@
 menu "ndisc6............................ IPv6 discovery tools"
 
 config BR2_COMPILE_NDISC6
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_NDISC6 || BR2_PACKAGE_RDISC6 || BR2_PACKAGE_TCPTRACEROUTE6
 
index 80c972cca0e6cd2e904c4dd718212972a4588837..e0a6d0387efacf75824aa5d8d74fce878b3fdb87 100644 (file)
@@ -1,7 +1,7 @@
 menu "net-snmp.......................... Open source SNMP (Simple Network Management Protocol) implementation"
 
 config BR2_COMPILE_NET_SNMP
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBNETSNMP || BR2_PACKAGE_SNMPD_STATIC
 
index f96bd0a90b488bf26999516de585b0df79610554..589b095196dbd91cabe64af19b4748c375d7a82c 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_OPENCDK
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBOPENCDK
 
index 1afab0c8334a7d2b0b167c8e5b7fc90aed0e41e2..ec04eb4bcd9d735420a5773cf2b0786a778fc3f4 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_OPENLDAP
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBOPENLDAP
 
index 6b344f897084290c83acdd6ade5b275a2744224b..387ee51fc6a9491fd3493542eab18c33120ad106 100644 (file)
@@ -1,7 +1,7 @@
 menu "openssh........................... A free implementation of the Secure Shell protocol"
 
 config BR2_COMPILE_OPENSSH
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_OPENSSH_CLIENT || BR2_PACKAGE_OPENSSH_SERVER || BR2_PACKAGE_OPENSSH_SFTP_CLIENT || BR2_PACKAGE_OPENSSH_SFTP_SERVER
 
index c81c2461c9f5baad51f3ce5b7c0184ec0b98dac2..e852c9f0f475c5e723744b69d1745aa38e2e372c 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_OPENSSL
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBOPENSSL
        
index 9a3d0a470d9c6a8ba68be32dfce7f100cce7d166..69afb907781410d2d6c1021d7d082e66a0a644e8 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_OSIRIS
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_OSIRISD
 
index dcbcfae588567b676fb02c0ef8a649ccc00f420b..7bb2de691330743e353c47b5e6d1271877e930b5 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_PCRE
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBPCRE
 
index 434b1f341c7be3dca9283d3d874d5fcaae6cb1e9..087a62c39ba760e0674770bc7edf87223106d54e 100644 (file)
@@ -1,7 +1,7 @@
 menu "php4.............................. PHP4 Hypertext preprocessor"
 
 config BR2_COMPILE_PHP4
-       bool
+       tristate
        default y
        depends BR2_PACKAGE_PHP4_CLI || BR2_PACKAGE_PHP4_CGI || BR2_PACKAGE_PHP4_FASTCGI
         
index cae12e4d4c9732d60b1c00a6a29f89ee939e0300..862df9953879411d2f349e51fef77089c2d61540 100644 (file)
@@ -1,7 +1,7 @@
 menu "php5.............................. PHP5 Hypertext preprocessor"
 
 config BR2_COMPILE_PHP5
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_PHP5_CLI || BR2_PACKAGE_PHP5_CGI || BR2_PACKAGE_PHP5_FASTCGI
         
index b06933ae7d504f64248328b7287e751f62eccc65..a24882b6c3e992d89174e1abfd1d22c565960279 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_POPT
-       bool
+       tristate
        depends BR2_PACKAGE_LIBPOPT
 
 config BR2_PACKAGE_LIBPOPT
index dc9555f9050939f901c6546dfb084987c4f6182d..776dccc4e80f6958f60578d3c4b3b0a2e3616db0 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_POSTGRESQL
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBPQ
 
index deca0d6448e5bf4f4e8971f12a6699c713ebc29e..9c5519b4d9f61495a87887e549f646de59430897 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_READLINE
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBREADLINE
 
index 2b4d9f21bd37ef09da96bb9525d1ecfde7c32a9a..a88b09b0cf3678c2257b51569118ddaa4dc2dd84 100644 (file)
@@ -1,7 +1,7 @@
 #menu "rp-pppoe.......................... Roaring Penguin PPPoE (PPP over Ethernet) implementation"
 
 config BR2_COMPILE_RP_PPPOE
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_PPPOE_CLIENT || BR2_PACKAGE_PPPOE_RELAY || BR2_PACKAGE_PPPOE_SERVER || BR2_PACKAGE_PPPOE_SNIFF
 
index de01aca2b013bb43dec1cb845165ef3e93908288..e79df5b4aac3dd49da9bc98be932750bbf5d7439 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_COMPILE_RRDTOOL1
        prompt "rrdtool1.......................... Round Robin Database (RRD) tools (v1.0.x)"
-       bool
-       default y
+       tristate
+       default m if CONFIG_DEVEL
 
 config BR2_PACKAGE_LIBRRD1
        prompt   "librrd1......................... Round Robin Database (RRD) management library (v1.0.x)"
@@ -53,6 +53,7 @@ config BR2_PACKAGE_RRDCGI1
 config BR2_PACKAGE_RRDTOOL1
        prompt   "rrdtool1........................ Round Robin Database (RRD) management tools (v1.0.x)"
        tristate
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_RRDTOOL1
        select BR2_PACKAGE_LIBRRD1
        help
index 30651d1f23322b3b6f19031f81bf2708ae4d78ac..28a3f0bde2235e1bbc3b51b18c803aa6adbf9140 100644 (file)
@@ -1,7 +1,7 @@
 #menu "rrs............................... A reverse (connecting) remote shell"
 
 config BR2_COMPILE_RRS
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_RRS || BR2_PACKAGE_RRS_NOSSL
 
index 9b57f0d78af6bfa0dd82805ebbabb7ac23da1c60..4aef84db33afc650e44af5235f9b707784bcdcfa 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_SABLEVM_CLASSPATH
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBSABLEVM_CLASSPATH
 
index 4382216203cae0c35ddc66dae021471e24d7e9ee..bf018509cfe7be14cc9be3de0c817e9cb2730366 100644 (file)
@@ -1,7 +1,7 @@
 #menu "samba............................. A NetBIOS/SMB implementation"
 
 config BR2_COMPILE_SAMBA
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_SAMBA || BR2_PACKAGE_SAMBA_CLIENT || BR2_PACKAGE_SMBFS
 
index 2ab0610030da13b2652465edcd6be454b798d16d..b7c7cfa85901430e4ad1771d6fbab9624283d0f8 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_SHFS
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_SHFS_UTILS
 
index 800de56a70807a282e030f3a749f8e9affa5c343..2a51044650d607d0e8d81131e92cfda08ff39607 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_SPEEX
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBSPEEX
 
index 626c5c3dcba74cf411239e9adc03165c8fa059d4..600a05e1544c8e70bfb870743d77a9e59761d8d8 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_SQLITE
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBSQLITE
 
index edab7b1c0584327cd1a41c8c739ca823bee4a2d9..99ba351c8ac10b27195e181e4d3631afacec62c9 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_SQLITE2
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_LIBSQLITE2
 
index b3e88d59e7da24ab3cdd0e3d0e4ed5e8a8f9bbb1..c9f525be5bd77a3e480365dd55ddabcfe480428b 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_COMPILE_USBUTILS
-       bool
+       tristate
        depends BR2_PACKAGE_LSUSB
 
 config BR2_PACKAGE_LSUSB
index 87d41ea499425cdbdb2e9af61db662f66d89e557..9f1c3a7f97dd0b71cae40b4d0cd5fb2b8bb6c7f8 100644 (file)
@@ -1,7 +1,7 @@
 menu "util-linux"
 
 config BR2_COMPILE_UTIL_LINUX
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_FDISK || BR2_PACKAGE_SWAP_UTILS