Add support for nokia n810 sound
authorMichael Büsch <mb@bu3sch.de>
Thu, 7 Oct 2010 15:35:49 +0000 (15:35 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 7 Oct 2010 15:35:49 +0000 (15:35 +0000)
SVN-Revision: 23303

package/kernel/modules/sound.mk
target/linux/omap24xx/patches-2.6.36/750-n810-sound-fixes.patch [new file with mode: 0644]
target/linux/omap24xx/patches-2.6.36/900-n810-battery-management.patch

index 7b647238dbb8a91c143642d8b4052e8d0f3ee236..da56f25e8b68b567a1129f859ada701e26fa7872 100644 (file)
@@ -146,3 +146,44 @@ define KernelPackage/sound-soc-core
 endef
 
 $(eval $(call KernelPackage,sound-soc-core))
 endef
 
 $(eval $(call KernelPackage,sound-soc-core))
+
+
+define KernelPackage/sound-soc-omap
+  TITLE:=OMAP SoC sound support
+  KCONFIG:= \
+       CONFIG_SND_OMAP_SOC
+  FILES:=$(LINUX_DIR)/sound/soc/omap/snd-soc-omap.ko
+  AUTOLOAD:=$(call AutoLoad,60,snd-soc-omap)
+  DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-core
+  $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-omap))
+
+
+define KernelPackage/sound-soc-omap-mcbsp
+  TITLE:=OMAP SoC MCBSP support
+  KCONFIG:= \
+       CONFIG_SND_OMAP_SOC_MCBSP
+  FILES:=$(LINUX_DIR)/sound/soc/omap/snd-soc-omap-mcbsp.ko
+  AUTOLOAD:=$(call AutoLoad,61,snd-soc-omap-mcbsp)
+  DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-omap
+  $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-omap-mcbsp))
+
+
+define KernelPackage/sound-soc-n810
+  TITLE:=Nokia n810 SoC sound support
+  KCONFIG:= \
+       CONFIG_SND_OMAP_SOC_N810
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-tlv320aic3x.ko \
+       $(LINUX_DIR)/sound/soc/omap/snd-soc-n810.ko
+  AUTOLOAD:=$(call AutoLoad,65,snd-soc-tlv320aic3x snd-soc-n810)
+  DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-omap +kmod-sound-soc-omap-mcbsp
+  $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-n810))
diff --git a/target/linux/omap24xx/patches-2.6.36/750-n810-sound-fixes.patch b/target/linux/omap24xx/patches-2.6.36/750-n810-sound-fixes.patch
new file mode 100644 (file)
index 0000000..039c59f
--- /dev/null
@@ -0,0 +1,61 @@
+---
+ arch/arm/mach-omap2/board-n8x0.c |   14 ++++++++++++++
+ sound/soc/omap/n810.c            |   10 ----------
+ 2 files changed, 14 insertions(+), 10 deletions(-)
+
+--- linux-2.6.36-rc7.orig/arch/arm/mach-omap2/board-n8x0.c
++++ linux-2.6.36-rc7/arch/arm/mach-omap2/board-n8x0.c
+@@ -906,6 +906,20 @@ static void __init n8x0_gpio_switches_in
+                                   ARRAY_SIZE(n8x0_gpio_switches));
+ }
++static struct i2c_board_info n810_tlc320aic3x_i2c_dev[] = {
++      { I2C_BOARD_INFO("tlv320aic3x", 0x1b), }
++};
++
++static int __init n810_tlv320aic3x_register(void)
++{
++      if (machine_is_nokia_n810() || machine_is_nokia_n810_wimax()) {
++              i2c_register_board_info(1, n810_tlc320aic3x_i2c_dev,
++                                      ARRAY_SIZE(n810_tlc320aic3x_i2c_dev));
++      }
++      return 0;
++}
++arch_initcall(n810_tlv320aic3x_register);
++
+ static void __init n8x0_init_machine(void)
+ {
+       omap2420_mux_init(board_mux, OMAP_PACKAGE_ZAC);
+--- linux-2.6.36-rc7.orig/sound/soc/omap/n810.c
++++ linux-2.6.36-rc7/sound/soc/omap/n810.c
+@@ -22,7 +22,6 @@
+  */
+ #include <linux/clk.h>
+-#include <linux/i2c.h>
+ #include <linux/platform_device.h>
+ #include <sound/core.h>
+ #include <sound/pcm.h>
+@@ -336,13 +335,6 @@ static struct snd_soc_device n810_snd_de
+ static struct platform_device *n810_snd_device;
+-/* temporary i2c device creation until this can be moved into the machine
+- * support file.
+-*/
+-static struct i2c_board_info i2c_device[] = {
+-      { I2C_BOARD_INFO("tlv320aic3x", 0x1b), }
+-};
+-
+ static int __init n810_soc_init(void)
+ {
+       int err;
+@@ -351,8 +343,6 @@ static int __init n810_soc_init(void)
+       if (!(machine_is_nokia_n810() || machine_is_nokia_n810_wimax()))
+               return -ENODEV;
+-      i2c_register_board_info(1, i2c_device, ARRAY_SIZE(i2c_device));
+-
+       n810_snd_device = platform_device_alloc("soc-audio", -1);
+       if (!n810_snd_device)
+               return -ENOMEM;
index 5e4c8208d01feec756e3744e5f35783b4eb2cf40..6dd3682b1a25822464ad15e2e8b4509d388be362 100644 (file)
  int retu_request_irq(int id, void *irq_handler, unsigned long arg, char *name);
 --- linux-2.6.36-rc7.orig/arch/arm/mach-omap2/board-n8x0.c
 +++ linux-2.6.36-rc7/arch/arm/mach-omap2/board-n8x0.c
  int retu_request_irq(int id, void *irq_handler, unsigned long arg, char *name);
 --- linux-2.6.36-rc7.orig/arch/arm/mach-omap2/board-n8x0.c
 +++ linux-2.6.36-rc7/arch/arm/mach-omap2/board-n8x0.c
-@@ -906,6 +906,17 @@ static void __init n8x0_gpio_switches_in
-                                   ARRAY_SIZE(n8x0_gpio_switches));
+@@ -920,6 +920,17 @@ static int __init n810_tlv320aic3x_regis
  }
  }
+ arch_initcall(n810_tlv320aic3x_register);
  
 +static struct platform_device n810_bm_device = {
 +      .name           = "n810bm",
  
 +static struct platform_device n810_bm_device = {
 +      .name           = "n810bm",
  static void __init n8x0_init_machine(void)
  {
        omap2420_mux_init(board_mux, OMAP_PACKAGE_ZAC);
  static void __init n8x0_init_machine(void)
  {
        omap2420_mux_init(board_mux, OMAP_PACKAGE_ZAC);
-@@ -933,6 +944,8 @@ static void __init n8x0_init_machine(voi
+@@ -947,6 +958,8 @@ static void __init n8x0_init_machine(voi
        n8x0_onenand_init();
        n8x0_mmc_init();
        n8x0_usb_init();
        n8x0_onenand_init();
        n8x0_mmc_init();
        n8x0_usb_init();