gpsd fixes:
authorNicolas Thill <nico@openwrt.org>
Tue, 29 Jul 2008 23:55:44 +0000 (23:55 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 29 Jul 2008 23:55:44 +0000 (23:55 +0000)
 - linking against uClibc++ alone doesn't work (because of libtool), so use libstdc++ instead (closes: #3139)
 - uClibc now has the necessary math functions, don't use libnotimpl anymore
 - explicitly disable dbus
 - use PKG_INSTALL_DIR and make install

SVN-Revision: 12000

net/gpsd/Makefile

index 467479ae21fd8ba84e251aa0717d2aa22a7643ba..29f396bc8d8f353c77c27713c97180dfc2cb0211 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpsd
 PKG_VERSION:=2.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
@@ -18,19 +18,20 @@ PKG_MD5SUM:=6c96cc0b2df0279cb7baac1ebc5881d3
 
 PKG_FIXUP = libtool
 
-PKG_BUILD_DEPENDS=libncurses libnotimpl
+PKG_BUILD_DEPENDS=libncurses
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gpsd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread +uclibcxx
+  DEPENDS:=+libpthread +libstdcpp
   TITLE:=An interface daemon for GPS receivers
   URL:=http://gpsd.berlios.de/
 endef
 
 CONFIGURE_ARGS += \
+       --disable-dbus \
        --disable-python \
        --disable-sirf \
        --disable-tsip \
@@ -49,31 +50,24 @@ CONFIGURE_ARGS += \
        --disable-reconfigure \
        --without-x \
 
-CONFIGURE_VARS += \
-       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-       LIBS="-nodefaultlibs -luClibc++ -lnotimpl" \
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               ./autogen.sh \
-       );
-       $(call Build/Configure/Default)
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/gps{,d}.h $(1)/usr/include/
-       $(CP) $(PKG_BUILD_DIR)/libgpsmm.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/.libs/libgps.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gps.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/gpsd/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/libgps.so.* $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libgps.so.* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/gpsd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/gpsd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,gpsd))