taglib now uses uclibc++ and compiles again
authorFlorian Fainelli <florian@openwrt.org>
Thu, 30 Aug 2007 14:39:55 +0000 (14:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 30 Aug 2007 14:39:55 +0000 (14:39 +0000)
SVN-Revision: 8545

libs/taglib/Makefile

index e9471dcd1d806c91507e101edb11b47bc3cdc478..43c45dd178972be21c953ab57d286dfaa46fd329 100644 (file)
@@ -25,16 +25,22 @@ include $(INCLUDE_DIR)/package.mk
 define Package/taglib
   SECTION:=libs
   CATEGORY:=Libraries
 define Package/taglib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib
+  DEPENDS:=+zlib +uclibcxx
   TITLE:=Audio output library
   DESCRIPTION:=\
        the audio output library
   URL:=http://developer.kde.org/~wheeler/taglib.html
 endef
 
   TITLE:=Audio output library
   DESCRIPTION:=\
        the audio output library
   URL:=http://developer.kde.org/~wheeler/taglib.html
 endef
 
+CONFIGURE_VARS += \
+        CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++ -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include"
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-final \
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-final \
+               ,\
+               LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+                LIBS="-luClibc++ -lc -lm -lgcc -lz" \
        )
 endef
 
        )
 endef