Update gnults to 2.4.1, package psktool as well (#3787)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 27 Jul 2008 12:34:42 +0000 (12:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 27 Jul 2008 12:34:42 +0000 (12:34 +0000)
SVN-Revision: 11958

libs/gnutls/Makefile

index 5009eaadefad6aa51e1934b18bd54291ad77ed75..f7cb18feac493a001ddff269ecc341456aa1f090 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=2.4.0
+PKG_VERSION:=2.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnut
        ftp://ftp.gnutls.org/pub/gnutls/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
        http://josefsson.org/gnutls/releases/
        ftp://ftp.gnutls.org/pub/gnutls/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
        http://josefsson.org/gnutls/releases/
-PKG_MD5SUM:=dce4000841ba5f80d310c4972b5f3efe
+PKG_MD5SUM:=573db36cb3f8472b0293cfa1f52c607a
 
 PKG_FIXUP = libtool
 
 
 PKG_FIXUP = libtool
 
@@ -62,8 +62,8 @@ endef
 
 define Package/gnutls-utils/description
 $(call Package/gnutls/Default/description)
 
 define Package/gnutls-utils/description
 $(call Package/gnutls/Default/description)
- This package contains the GnuTLS gnutls-cli, gnutls-serv and psktool
- utilities.
+ This package contains the GnuTLS gnutls-cli, gnutls-serv, psktool,
and srptool utilities.
 endef
 
 
 endef
 
 
@@ -106,13 +106,10 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
-       --disable-psk-authentication \
-       --disable-srp-authentication \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
        --with-libz-prefix="$(STAGING_DIR)/usr" \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
        --with-libz-prefix="$(STAGING_DIR)/usr" \
-       --with-libtasn1-prefix="$(STAGING_DIR)/usr" \
-       --without-lzo
+       --with-libtasn1-prefix="$(STAGING_DIR)/usr"
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \
@@ -152,6 +149,7 @@ define Package/gnutls-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psktool $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/psktool $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/srptool $(1)/usr/bin/
 endef
 
 
 endef