check for empty patch directories
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 15:09:03 +0000 (15:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 15:09:03 +0000 (15:09 +0000)
SVN-Revision: 5086

include/package.mk

index 706b38d12a20a1b43369f8b03b15535d8c87845d..87e76be2b53248470485c0c317310ce490111038 100644 (file)
@@ -273,7 +273,7 @@ endef
 ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
 ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
-       @if [ -d ./patches ]; then \
+       @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
   endef
                $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
   endef