update alsa-driver to 1.1.14rc1 (fix build on 2.6.19)
authorNicolas Thill <nico@openwrt.org>
Fri, 15 Dec 2006 15:45:15 +0000 (15:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 15 Dec 2006 15:45:15 +0000 (15:45 +0000)
SVN-Revision: 5798

package/alsa/Makefile
package/alsa/patches/110-cp_command.patch

index 7bd155078ed1377a85b7fdeb9e69cee3749d4ba1..320a918414020f0072885c5479f1450a8221db1a 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=alsa-driver
-PKG_VERSION:=1.0.11
+PKG_VERSION:=1.0.14rc1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
-PKG_MD5SUM:=57534e4297cd683371402220e3753885
+PKG_MD5SUM:=4cff99be4b225e96663fbd61cabe3182
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
index 68499e883748e2969f34e47c7a33a6dc65a75248..4684f9edde1848e43daf37777e890c44d81b6abc 100644 (file)
@@ -1,19 +1,11 @@
-diff -ur alsa.old/Makefile alsa.dev/Makefile
---- alsa.old/Makefile  2006-10-14 07:07:48.000000000 -0700
-+++ alsa.dev/Makefile  2006-10-14 07:08:45.000000000 -0700
-@@ -100,6 +100,7 @@
- SUBDIRS  += parisc
- endif
- CSUBDIRS += include test utils
-+CP = cp -fPR
- KCONFIG_FILES = $(shell find $(SND_TOPDIR) -name Kconfig) $(shell find $(SND_TOPDIR)/alsa-kernel/ -name Kconfig)
-@@ -115,7 +116,7 @@
+diff -ruN alsa-driver-1.0.14rc1-old/Makefile alsa-driver-1.0.14rc1-new/Makefile
+--- alsa-driver-1.0.14rc1-old/Makefile 2006-12-15 16:23:38.000000000 +0100
++++ alsa-driver-1.0.14rc1-new/Makefile 2006-12-15 16:24:57.000000000 +0100
+@@ -116,7 +116,7 @@
        if [ ! -d include/sound -a ! -L include/sound ]; then \
          ln -sf ../alsa-kernel/include include/sound ; \
        fi
--      cp -auvf include/version.h include/sound/version.h
+-      cp -puvf include/version.h include/sound/version.h
 +      $(CP) include/version.h include/sound/version.h
  
  utils/mod-deps: utils/mod-deps.c