[paclages] rcs: fix wrong path used by rcs to look for co & merge utilities (closes...
authorNicolas Thill <nico@openwrt.org>
Sun, 27 Sep 2009 15:30:22 +0000 (15:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 27 Sep 2009 15:30:22 +0000 (15:30 +0000)
SVN-Revision: 17765

utils/rcs/Makefile
utils/rcs/patches/100-cross_compile.patch

index 4ed731dddcd50e5b956787bb8b5c6190e073b850..838fe8a930d10d038756414d2e6eeb2ef90607c7 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rcs
 PKG_VERSION:=5.7
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -32,11 +32,6 @@ define Package/$(PKG_NAME)/desctiption
  programs, documentation, graphics, papers, and form letters.
 endef
 
-define Build/Compile
-       touch $(PKG_BUILD_DIR)/src/conf.h
-       $(call Build/Compile/Default)
-endef
-
 define Package/$(PKG_NAME)/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/{ci,co,ident,merge,rcs,rcsclean,rcsdiff,rcsmerge,rlog} $(1)/usr/bin
index b61f31763d76e3dca26d24b18784afcdff10ed4c..665ca0fbb2c436eddbc914c7a13234d9d4dc4b59 100644 (file)
 +/* Do struct stat s and t describe the same file?  Answer d if unknown.  */
 +#define same_file(s,t,d) ((s).st_ino==(t).st_ino && (s).st_dev==(t).st_dev)
 +#define has_utimbuf 1 /* Does struct utimbuf work?  */
-+#define CO "/usr/local/bin/co" /* name of 'co' program */
++#define CO "/usr/bin/co" /* name of 'co' program */
 +#define COMPAT2 0 /* Are version 2 files supported?  */
 +#define DIFF "/usr/bin/diff" /* name of 'diff' program */
 +#define DIFF3 "/usr/bin/diff3" /* name of 'diff3' program */
 +#define DIFF_FAILURE 1 /* DIFF status if differences are found */
 +#define DIFF_TROUBLE 2 /* DIFF status if trouble */
 +#define ED "/bin/ed" /* name of 'ed' program (used only if !DIFF3_BIN) */
-+#define MERGE "/usr/local/bin/merge" /* name of 'merge' program */
++#define MERGE "/usr/bin/merge" /* name of 'merge' program */
 +#define TMPDIR "/tmp" /* default directory for temporary files */
 +#define SLASH '/' /* principal filename separator */
 +#define SLASHes '/' /* `case SLASHes:' labels all filename separators */