[package] firewall: enable /etc/firewall.user by default and install sample firewall...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Apr 2009 22:38:34 +0000 (22:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Apr 2009 22:38:34 +0000 (22:38 +0000)
SVN-Revision: 15221

package/firewall/Makefile
package/firewall/files/firewall.config [changed mode: 0755->0644]
package/firewall/files/firewall.user [new file with mode: 0644]

index 9d4e5dd31a727e6de1573058b04ebb424006e109..7aa385511f76a32f4fbc875cfeb233728e59aff1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
old mode 100755 (executable)
new mode 100644 (file)
index 46f7de5..464540f
@@ -22,6 +22,10 @@ config forwarding
        option dest     wan
        option mtu_fix  1
 
+# include a file with users custom iptables rules
+config include
+       option path /etc/firewall.user
+
 
 ### EXAMPLE CONFIG SECTIONS
 # do not allow a specific ip to access wan
@@ -53,10 +57,6 @@ config forwarding
 #      option dest_port        80 
 #      option proto            tcp
 
-# include a file with users custom iptables rules
-#config include
-#      option path /etc/firewall.user
-
 
 ### FULL CONFIG SECTIONS
 #config rule
diff --git a/package/firewall/files/firewall.user b/package/firewall/files/firewall.user
new file mode 100644 (file)
index 0000000..1ccbd01
--- /dev/null
@@ -0,0 +1,4 @@
+# This file is interpreted as shell script.
+# Put your custom iptables rules here, they will
+# be executed with each firewall (re-)start.
+