separate series file fixup from quilt check to avoid series file breakages after...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 4 Oct 2007 15:32:55 +0000 (15:32 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 4 Oct 2007 15:32:55 +0000 (15:32 +0000)
SVN-Revision: 9120

include/quilt.mk

index 667653f320b30f6d096dbbf739d00243510850b5..daeef9431ffef66fbd5f36f56aedcbba49ec72b1 100644 (file)
@@ -54,10 +54,11 @@ endef
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
+  STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
   override CONFIG_AUTOREBUILD=
   override CONFIG_AUTOREBUILD=
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
+  $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   prepare: $(STAMP_PATCHED)
   prepare: $(STAMP_PATCHED)
-  quilt-check: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_CHECKED)
 endif
 
 define Build/Patch/Default
 endif
 
 define Build/Patch/Default
@@ -119,6 +120,9 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
                        find * -type f \! -name series | sort > series; \
                fi; \
        )
                        find * -type f \! -name series | sort > series; \
                fi; \
        )
+       touch $@
+
+$(STAMP_CHECKED): $(STAMP_PATCHED)
        if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
 
        if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@