ramips: image: cleanup and sort templates/profiles
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Feb 2012 19:58:15 +0000 (19:58 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Feb 2012 19:58:15 +0000 (19:58 +0000)
SVN-Revision: 30705

target/linux/ramips/image/Makefile

index e0acaedd3325f0572f1975a7928adad0513f9b6c..d303ed8b39fd6e8b3718cf75d4a80bebd62505d3 100644 (file)
@@ -104,22 +104,31 @@ define BuildFirmware/Generic/initramfs
        $(CP) $(KDIR)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
 endef
 
-define BuildFirmware/WL341V3
-       $(call MkImageLzma,$(2),$(3))
-       $(call Sysupgrade/KRuImage,$(1),$(2),$(4),$(5))
-       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
-               ( \
-                       dd if=/dev/zero bs=195936 count=1; \
-                       echo "1.01"; \
-                       dd if=/dev/zero bs=581 count=1; \
-                       echo -n -e "\x73\x45\x72\x43\x6F\x4D\x6D\x00\x01\x00\x00\x59\x4E\x37\x95\x58\x10\x00\x20\x00\x28\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x11\x03\x00\x00\x80\x00\x00\x00\x00\x03\x00\x00\x10\x12\x00\x00\x00\x10\x73\x45\x72\x43\x6F\x4D\x6D"; \
-                       dd if=/dev/zero bs=65552 count=1; \
-                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=$(4) conv=sync; \
-                       dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-                       dd if=/dev/zero bs=`expr 4194304 - 262144 - 16 - $(4) - \( \( \( \`stat -c%s $(KDIR)/root.$(1)\` / 65536 \) + 1 \) \* 65536 \)` count=1; \
-                       echo -n -e "\x11\x03\x80\x00\x10\x12\x90\xF7\x65\x52\x63\x4F\x6D\x4D\x00\x00"; \
-               ) > $(call imgname,$(1),$(2))-factory.bin; \
-       fi
+mtdlayout_4M=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+define BuildFirmware/GENERIC_4M
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)),851968,3014656)
+endef
+
+define BuildFirmware/GENERIC_4M/initramfs
+       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)))
+endef
+
+mtdlayout_8M=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,896k(kernel),6976k(rootfs),7872k@0x50000(firmware)
+kernel_size_8M=917504
+rootfs_size_8M=7143424
+define BuildFirmware/GENERIC_8M
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_8M)),$(kernel_size_8M),$(rootfs_size_8M))
+endef
+
+define BuildFirmware/GENERIC_8M/initramfs
+       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_8M)))
+endef
+
+mtdlayout_argus_atp52b=192k(bootloader)ro,64k(config),64k(factory),1152k(kernel),6656k(rootfs),7808k@0x50000(firmware)
+mtd_argus_atp52b_kernel_part_size=1179648
+mtd_argus_atp52b_rootfs_part_size=6815744
+define BuildFirmware/ARGUS_ATP52B
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_argus_atp52b)),$(mtd_argus_atp52b_kernel_part_size),$(mtd_argus_atp52b_rootfs_part_size))
 endef
 
 define BuildFirmware/Buffalo
@@ -140,92 +149,150 @@ define BuildFirmware/Buffalo
        fi
 endef
 
+
 define BuildFirmware/Buffalo2
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(4),$(5),$(6))
 endef
 
+mtdlayout_dir300b1=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,896k(kernel),2880k(rootfs),3776k@0x50000(firmware)
+mtd_dir300b1_kernel_part_size=917504
+mtd_dir300b1_rootfs_part_size=2949120
+define BuildFirmware/DIR300B1
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
+       mkwrgimg -s $(4) -d /dev/mtdblock/2 \
+               -i $(call sysupname,$(1),$(2)) \
+               -o $(call imgname,$(1),$(2))-factory.bin
+endef
+
+define BuildFirmware/Edimax
+       mkedimaximg -i $(call sysupname,$(1),$(2)) \
+               -o $(call imgname,$(1),$(2))-factory.bin \
+               -s $(3) -m $(4) -f $(5) -S $(6)
+endef
+
+mtdlayout_f5d8235=320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
+mtd_f5d8235_kernel_part_size=1572864
+mtd_f5d8235_rootfs_part_size=6356992
+define BuildFirmware/F5D8235
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call  mkmtd/phys,$(mtdlayout_f5d8235)),$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
+
+define BuildFirmware/FONERA20N
+       $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N,ttyS1,57600,phys)
+       $(call BuildFirmware/Edimax,$(1),fonera20n,RSDK,NL1T,0x50000,0xc0000)
+endef
+
+mtdlayout_nw718=192k(u-boot)ro,128k(config)ro,64k(factory)ro,832k(kernel),2880k(rootfs),3712k@0x60000(firmware)
+kernel_size_nw718=851968
+rootfs_size_nw718=2949120
+cmdline_nw718=$(call mkcmdline,NW718,ttyS1,57600) $(call mkmtd/spi,$(mtdlayout_nw718))
 define BuildFirmware/NW718
-       $(call PatchKernelLzma,$(2),$(3))
+       $(call BuildFirmware/Generic,$(1),$(2),$(cmdline_nw718),$(kernel_size_nw718),$(rootfs_size_nw718))
+       $(call PatchKernelLzma,$(2),$(cmdline_nw718))
        mkimage -A mips -O linux -T kernel -C lzma $(call kernel_entry) \
                -n "ARA1B4NCRNW718;1" \
                -d "$(KDIR)/vmlinux-$(2).bin.lzma" \
                "$(KDIR)/vmlinux-$(2).uImage"
-       if [ `stat -c%s "$(KDIR)/vmlinux-$(2).uImage"` -gt $(4) ]; then \
-               echo "Warning: $(KDIR)/vmlinux-$(2).uImage is too big"; \
-       else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(5) ]; then \
-               echo "Warning: $(KDIR)/root.$(1) is too big"; \
-       else \
+       $(call CatFiles,$(KDIR)/vmlinux-$(2).uImage,$(kernel_size_nw718),$(KDIR)/root.$(1),$(rootfs_size_nw718),$(call imgname,$(1),$(2))-factory.bin)
+endef
+
+mtdlayout_rtg32b1=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+mtd_rtg32b1_kernel_part_size=851968
+mtd_rtg32b1_rootfs_part_size=3014656
+define BuildFirmware/RTG32B1
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/spi,$(mtdlayout_rtg32b1)),$(mtd_rtg32b1_kernel_part_size),$(mtd_rtg32b1_rootfs_part_size))
+endef
+
+mtdlayout_whrg300n=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,960k(kernel),2752k(rootfs),64k(user)ro,3712k@0x50000(firmware)
+define BuildFirmware/WHRG300N
+       $(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N,ttyS1,57600,phys)
+       $(call BuildFirmware/Buffalo,$(1),whr-g300n,$(call mkcmdline,WHR-G300N,ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_whrg300n)),983040,3801088)
+       ( \
+               echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
+                       dd bs=512 count=1 conv=sync; \
+               dd if=$(call sysupname,$(1),whr-g300n); \
+       ) > $(KDIR)/whr-g300n-tftp.tmp
+       buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
+               -o $(call imgname,$(1),whr-g300n)-tftp.bin
+endef
+
+mtdlayout_wl341v3=128k(u-boot)ro,64k(board-nvram)ro,64k(u-boot-env)ro,832k(kernel),2944k(rootfs),64k(signature-eRcOmM),3776k@0x40000(firmware),4096k@0x0(fullflash)
+kernel_size_wl341v3=851968
+rootfs_size_wl341v3=3014656
+define BuildFirmware/WL341V3
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_wl341v3)),$(kernel_size_wl341v3),$(rootfs_size_wl341v3))
+       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
                ( \
-                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=$(4) conv=sync; \
+                       dd if=/dev/zero bs=195936 count=1; \
+                       echo "1.01"; \
+                       dd if=/dev/zero bs=581 count=1; \
+                       echo -n -e "\x73\x45\x72\x43\x6F\x4D\x6D\x00\x01\x00\x00\x59\x4E\x37\x95\x58\x10\x00\x20\x00\x28\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x11\x03\x00\x00\x80\x00\x00\x00\x00\x03\x00\x00\x10\x12\x00\x00\x00\x10\x73\x45\x72\x43\x6F\x4D\x6D"; \
+                       dd if=/dev/zero bs=65552 count=1; \
+                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=$(kernel_size_wl341v3) conv=sync; \
                        dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+                       dd if=/dev/zero bs=`expr 4194304 - 262144 - 16 - $(kernel_size_wl341v3) - \( \( \( \`stat -c%s $(KDIR)/root.$(1)\` / 65536 \) + 1 \) \* 65536 \)` count=1; \
+                       echo -n -e "\x11\x03\x80\x00\x10\x12\x90\xF7\x65\x52\x63\x4F\x6D\x4D\x00\x00"; \
                ) > $(call imgname,$(1),$(2))-factory.bin; \
-       fi; fi
+       fi
 endef
 
-define BuildFirmware/Edimax
-       mkedimaximg -i $(call sysupname,$(1),$(2)) \
-               -o $(call imgname,$(1),$(2))-factory.bin \
-               -s $(3) -m $(4) -f $(5) -S $(6)
+mtdlayout_wlitx4ag300n=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
+define BuildFirmware/WLITX4AG300N
+       $(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,$(call mkmtd/phys,$(mtdlayout_wlitx4ag300n)),851968,2949120)
 endef
 
+#
+# Templates
+#
 define Image/Build/Template/initramfs/initramfs
-       $(call Image/Build/Template/$(1)/initramfs,initramfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
+       $(call BuildFirmware/$(1)/initramfs,initramfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef
 
 define Image/Build/Template/squashfs-only/squashfs
-       $(call Image/Build/Template/$(1),squashfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
-endef
-
-mtdlayout_4M=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-define Image/Build/Template/GENERIC_4M
-       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)),851968,3014656)
+       $(call BuildFirmware/$(1),squashfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef
 
-define Image/Build/Template/GENERIC_4M/initramfs
-       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)))
+#
+# RT288X Profiles
+#
+define Image/Build/Profile/F5D8235V1
+       $(call Image/Build/Template/$(fs_squash)/$(1),F5D8235,f5d8235v1,F5D8235_V1)
 endef
 
-mtdlayout_8M=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,896k(kernel),6976k(rootfs),7872k@0x50000(firmware)
-kernel_size_8M=917504
-rootfs_size_8M=7143424
-define Image/Build/Template/GENERIC_8M
-       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_8M)),$(kernel_size_8M),$(rootfs_size_8M))
+define Image/Build/Profile/RTN15
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,rt-n15,RT-N15,ttyS1,57600,phys)
 endef
 
-define Image/Build/Template/GENERIC_8M/initramfs
-       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_8M)))
+define Image/Build/Profile/V11STFE
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,v11st-fe,V11ST-FE,ttyS1,57600,phys)
 endef
 
-mtdlayout_dir300b1=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,896k(kernel),2880k(rootfs),3776k@0x50000(firmware)
-mtd_dir300b1_kernel_part_size=917504
-mtd_dir300b1_rootfs_part_size=2949120
-define Image/Build/Template/DIR300B1
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
-       mkwrgimg -s $(4) -d /dev/mtdblock/2 \
-               -i $(call sysupname,$(1),$(2)) \
-               -o $(call imgname,$(1),$(2))-factory.bin
+define Image/Build/Profile/WLITX4AG300N
+       $(call Image/Build/Template/$(fs_squash)/$(1),WLITX4AG300N)
 endef
 
-mtdlayout_nw718=192k(u-boot)ro,128k(config)ro,64k(factory)ro,832k(kernel),2880k(rootfs),3712k@0x60000(firmware)
-mtdparts_nw718=$(mkmtd/spi,$(mtdlayout_nw718))
-define Image/Build/Template/NW718
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(mtdparts_nw718),851968,2949120)
-       $(call BuildFirmware/NW718,$(1),$(2),board=$(3) $(mtdparts_nw718),851968,2949120)
+ifeq ($(CONFIG_RALINK_RT288X),y)
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/F5D8235V1,$(1))
+       $(call Image/Build/Profile/RTN15,$(1))
+       $(call Image/Build/Profile/V11STFE,$(1))
+       $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef
+endif
 
-define Image/Build/Profile/WR6202
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr6202,WR6202,ttyS1,115200,phys)
+#
+# RT305X Profiles
+#
+define Image/Build/Profile/ALL0256N
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,all0256n,ALL0256N,ttyS1,57600,spi)
 endef
 
-mtdlayout_sercomm_4M=128k(u-boot)ro,64k(board-nvram)ro,64k(u-boot-env)ro,832k(kernel),2944k(rootfs),64k(signature-eRcOmM),3776k@0x40000(firmware),4096k@0x0(fullflash)
-mtdparts_sercomm_4M=$(call mkmtd/phys,$(mtdlayout_sercomm_4M))
-define Image/Build/Template/WL341V3
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(mtdparts_sercomm_4M),851968,3014656)
-       $(call BuildFirmware/WL341V3,$(1),$(2),board=$(3) $(mtdparts_sercomm_4M),851968,3014656)
+define Image/Build/Profile/ARGUS_ATP52B
+       $(call Image/Build/Template/$(fs_squash)/$(1),ARGUS_ATP52B,argus_atp52b,ARGUS_ATP52B)
 endef
 
-define Image/Build/Profile/WL341V3
-       $(call Image/Build/Template/$(fs_squash)/$(1),WL341V3,wl341v3,WL341V3)
+define Image/Build/Profile/BC2
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,bc2,BC2,ttyS1,57600,phys)
 endef
 
 define Image/Build/Profile/DIR300B1
@@ -234,48 +301,32 @@ define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-600-b2,DIR-600-B2,wrgn23_dlwbr_dir600b)
 endef
 
-mtdlayout_rtg32b1=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-mtd_rtg32b1_kernel_part_size=851968
-mtd_rtg32b1_rootfs_part_size=3014656
-define Image/Build/Template/RTG32B1
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/spi,$(mtdlayout_rtg32b1)),$(mtd_rtg32b1_kernel_part_size),$(mtd_rtg32b1_rootfs_part_size))
-endef
-
-define Image/Build/Profile/RTG32B1
-       $(call Image/Build/Template/$(fs_squash)/$(1),RTG32B1,rt-g32-b1,RT-G32-B1)
-endef
-
 define Image/Build/Profile/ESR9753
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,esr-9753,ESR-9753,ttyS1,57600,phys)
 endef
 
-define Image/Build/Template/FONERA20N
-       $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N,ttyS1,57600,phys)
-       $(call BuildFirmware/Edimax,$(1),fonera20n,RSDK,NL1T,0x50000,0xc0000)
+define Image/Build/Profile/HW5503G
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,hw550-3g,HW550-3G,ttyS1,57600,phys)
 endef
 
-define Image/Build/Profile/FONERA20N
-       $(call Image/Build/Template/$(fs_squash)/$(1),FONERA20N)
+define Image/Build/Profile/F5D8235V2
+       $(call Image/Build/Template/$(fs_squash)/$(1),F5D8235,f5d8235v2,F5D8235_V2)
 endef
 
-define Image/Build/Profile/BC2
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,bc2,BC2,ttyS1,57600,phys)
+define Image/Build/Profile/FONERA20N
+       $(call Image/Build/Template/$(fs_squash)/$(1),FONERA20N)
 endef
 
-define Image/Build/Profile/ALL0256N
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,all0256n,ALL0256N,ttyS1,57600,spi)
+define Image/Build/Profile/MOFI35003GN
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,mofi3500-3gn,MOFI3500-3GN,ttyS1,57600,phys)
 endef
 
 define Image/Build/Profile/NBG419N
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,nbg-419n,NBG419N,ttyS1,57600,phys)
 endef
 
-define Image/Build/Profile/WL351
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wl-351,WL-351,ttyS1,57600,phys)
-endef
-
 define Image/Build/Profile/NW718
-       $(call Image/Build/Template/$(fs_squash)/$(1),NW718,nw718,NW718)
+       $(call Image/Build/Template/$(fs_squash)/$(1),NW718,nw718)
 endef
 
 define Image/Build/Profile/OMNIEMB
@@ -286,63 +337,36 @@ define Image/Build/Profile/PWH2004
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,pwh2004,PWH2004,ttyS1,57600,phys)
 endef
 
-define Image/Build/Profile/V22RW2X2
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,v22rw-2x2,V22RW-2X2,ttyS1,57600,phys)
-endef
-
-mtdlayout_whrg300n=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,960k(kernel),2752k(rootfs),64k(user)ro,3712k@0x50000(firmware)
-define Image/Build/Template/WHRG300N
-       $(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N,ttyS1,57600,phys)
-       $(call BuildFirmware/Buffalo,$(1),whr-g300n,$(call mkcmdline,WHR-G300N,ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_whrg300n)),983040,3801088)
-       ( \
-               echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
-                       dd bs=512 count=1 conv=sync; \
-               dd if=$(call sysupname,$(1),whr-g300n); \
-       ) > $(KDIR)/whr-g300n-tftp.tmp
-       buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
-               -o $(call imgname,$(1),whr-g300n)-tftp.bin
-endef
-
-define Image/Build/Profile/WHRG300N
-       $(call Image/Build/Template/$(fs_squashfs)/$(1),WHRG300N)
-endef
-
-define Image/Build/Profile/HW5503G
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,hw550-3g,HW550-3G,ttyS1,57600,phys)
+define Image/Build/Profile/RTG32B1
+       $(call Image/Build/Template/$(fs_squash)/$(1),RTG32B1,rt-g32-b1,RT-G32-B1)
 endef
 
-define Image/Build/Profile/MOFI35003GN
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,mofi3500-3gn,MOFI3500-3GN,ttyS1,57600,phys)
+define Image/Build/Profile/SLR7205
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,sl-r7205,SL-R7205,ttyS1,57600,phys)
 endef
 
-define Image/Build/Profile/WCR150GN
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wcr150gn,WCR150GN,ttyS1,57600,phys)
+define Image/Build/Profile/V22RW2X2
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,v22rw-2x2,V22RW-2X2,ttyS1,57600,phys)
 endef
 
 define Image/Build/Profile/W502U
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,w502u,W502U,ttyS1,115200,phys)
 endef
 
-mtdlayout_argus_atp52b=192k(bootloader)ro,64k(config),64k(factory),1152k(kernel),6656k(rootfs),7808k@0x50000(firmware)
-mtd_argus_atp52b_kernel_part_size=1179648
-mtd_argus_atp52b_rootfs_part_size=6815744
-define Image/Build/Template/ARGUS_ATP52B
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_argus_atp52b)),$(mtd_argus_atp52b_kernel_part_size),$(mtd_argus_atp52b_rootfs_part_size))
+define Image/Build/Profile/WCR150GN
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wcr150gn,WCR150GN,ttyS1,57600,phys)
 endef
 
-define Image/Build/Profile/ARGUS_ATP52B
-       $(call Image/Build/Template/$(fs_squash)/$(1),ARGUS_ATP52B,argus_atp52b,ARGUS_ATP52B)
+define Image/Build/Profile/WHRG300N
+       $(call Image/Build/Template/$(fs_squashfs)/$(1),WHRG300N)
 endef
 
-mtdlayout_f5d8235=320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
-mtd_f5d8235_kernel_part_size=1572864
-mtd_f5d8235_rootfs_part_size=6356992
-define Image/Build/Template/F5D8235
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_f5d8235)),$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+define Image/Build/Profile/WL341V3
+       $(call Image/Build/Template/$(fs_squash)/$(1),WL341V3,wl341v3,WL341V3)
 endef
 
-define Image/Build/Profile/F5D8235V2
-       $(call Image/Build/Template/$(fs_squash)/$(1),F5D8235,f5d8235v2,F5D8235_V2)
+define Image/Build/Profile/WL351
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wl-351,WL-351,ttyS1,57600,phys)
 endef
 
 define Image/Build/Profile/WR5123GN
@@ -350,68 +374,38 @@ define Image/Build/Profile/WR5123GN
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr512-3gn-8M,WR512-3GN,ttyS1,57600,phys)
 endef
 
-define Image/Build/Profile/SLR7205
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,sl-r7205,SL-R7205,ttyS1,57600,phys)
+define Image/Build/Profile/WR6202
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr6202,WR6202,ttyS1,115200,phys)
 endef
 
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
-       $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/ESR9753,$(1))
-       $(call Image/Build/Profile/RTG32B1,$(1))
+       $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
-       $(call Image/Build/Profile/V22RW2X2,$(1))
+       $(call Image/Build/Profile/HW5503G,$(1))
+       $(call Image/Build/Profile/MOFI35003GN,$(1))
        $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/OMNIEMB,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
+       $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/SLR7205,$(1))
-       $(call Image/Build/Profile/WHRG300N,$(1))
-       $(call Image/Build/Profile/WCR150GN,$(1))
-       $(call Image/Build/Profile/F5D8235V2,$(1))
-       $(call Image/Build/Profile/HW5503G,$(1))
-       $(call Image/Build/Profile/MOFI35003GN,$(1))
+       $(call Image/Build/Profile/V22RW2X2,$(1))
        $(call Image/Build/Profile/W502U,$(1))
-       $(call Image/Build/Profile/WR5123GN,$(1))
+       $(call Image/Build/Profile/WCR150GN,$(1))
+       $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WL341V3,$(1))
        $(call Image/Build/Profile/WL351,$(1))
+       $(call Image/Build/Profile/WR5123GN,$(1))
        $(call Image/Build/Profile/WR6202,$(1))
 endef
 endif
 
-define Image/Build/Profile/F5D8235V1
-       $(call Image/Build/Template/$(fs_squash)/$(1),F5D8235,f5d8235v1,F5D8235_V1)
-endef
-
-define Image/Build/Profile/RTN15
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,rt-n15,RT-N15,ttyS1,57600,phys)
-endef
-
-define Image/Build/Profile/V11STFE
-       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,v11st-fe,V11ST-FE,ttyS1,57600,phys)
-endef
-
-mtdlayout_wlitx4ag300n=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
-define Image/Build/Template/WLITX4AG300N
-       $(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,$(call mkmtd/phys,$(mtdlayout_wlitx4ag300n)),851968,2949120)
-endef
-
-define Image/Build/Profile/WLITX4AG300N
-       $(call Image/Build/Template/$(fs_squash)/$(1),WLITX4AG300N)
-endef
-
-ifeq ($(CONFIG_RALINK_RT288X),y)
-define Image/Build/Profile/Default
-       $(call Image/Build/Profile/F5D8235V1,$(1))
-       $(call Image/Build/Profile/RTN15,$(1))
-       $(call Image/Build/Profile/V11STFE,$(1))
-       $(call Image/Build/Profile/WLITX4AG300N,$(1))
-endef
-endif
-
 define Image/Build/Initramfs
        $(call Image/Build/Profile/$(PROFILE),initramfs)
 endef