libamsel objects should be compiled with -fPIC to allow shared library generation...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 29 Jul 2008 08:17:00 +0000 (08:17 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 29 Jul 2008 08:17:00 +0000 (08:17 +0000)
SVN-Revision: 11984

libs/libamsel/Makefile

index 0305d329394d82b56aec963eebfd12901d33f1d2..d205f88730eb171cd1cb762c819489c4ef7a896a 100644 (file)
@@ -36,7 +36,7 @@ define Build/Configure
 endef
 
 MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)" \
+       CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -fPIC" \
        LDIR=$(PKG_BUILD_DIR) \
        PREFIX="$(PKG_INSTALL_DIR)/usr" \
        all install