[package/hotplug2] link against 'libbsd' when using glibc
authorMirko Vogt <mirko@openwrt.org>
Fri, 17 Jun 2011 22:51:20 +0000 (22:51 +0000)
committerMirko Vogt <mirko@openwrt.org>
Fri, 17 Jun 2011 22:51:20 +0000 (22:51 +0000)
SVN-Revision: 27209

package/hotplug2/Makefile

index 9625ba27f9c1dfab07daffe9ca7092991de3f264..699976e8a9d7800198ded3d1ed55bc2840594a46 100644 (file)
@@ -28,7 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
-  DEPENDS:=+USE_EGLIBC:libbsd
+  DEPENDS:=+USE_EGLIBC:libbsd +USE_GLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
   TARGET_LDFLAGS += -lbsd
 endif