[ar71xx] nuke 2.6.25 specific patches
authorGabor Juhos <juhosg@openwrt.org>
Thu, 18 Sep 2008 12:40:42 +0000 (12:40 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 18 Sep 2008 12:40:42 +0000 (12:40 +0000)
SVN-Revision: 12625

12 files changed:
target/linux/ar71xx/patches/001-ar71xx_core.patch [deleted file]
target/linux/ar71xx/patches/002-ar71xx_pci.patch [deleted file]
target/linux/ar71xx/patches/003-ar71xx_usb_host.patch [deleted file]
target/linux/ar71xx/patches/004-ar71xx_spi_controller.patch [deleted file]
target/linux/ar71xx/patches/005-ar71xx_mac_driver.patch [deleted file]
target/linux/ar71xx/patches/100-mtd_pm25lv_flash_support.patch [deleted file]
target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch [deleted file]
target/linux/ar71xx/patches/140-redboot_partition_scan.patch [deleted file]
target/linux/ar71xx/patches/200-rb4xx_nand_driver.patch [deleted file]
target/linux/ar71xx/patches/900-mips_multi_machine_support.patch [deleted file]
target/linux/ar71xx/patches/901-get_c0_compare_irq_function.patch [deleted file]
target/linux/ar71xx/patches/902-mips_clocksource_init_war.patch [deleted file]

diff --git a/target/linux/ar71xx/patches/001-ar71xx_core.patch b/target/linux/ar71xx/patches/001-ar71xx_core.patch
deleted file mode 100644 (file)
index 5806206..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -593,6 +593,13 @@
- cflags-$(CONFIG_TOSHIBA_RBTX4938) += -Iinclude/asm-mips/mach-tx49xx
- load-$(CONFIG_TOSHIBA_RBTX4938) += 0xffffffff80100000
-+#
-+# Atheros AR71xx
-+#
-+core-$(CONFIG_ATHEROS_AR71XX) += arch/mips/ar71xx/
-+cflags-$(CONFIG_ATHEROS_AR71XX)       += -Iinclude/asm-mips/mach-ar71xx
-+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
-+
- # temporary until string.h is fixed
- cflags-y += -ffreestanding
---- a/include/asm-mips/bootinfo.h
-+++ b/include/asm-mips/bootinfo.h
-@@ -79,6 +79,15 @@
- #define  MACH_LASAT_200               1       /* Masquerade PRO/SP200 */
- /*
-+ * Valid machtype for Atheros AR71xx based boards
-+ */
-+#define MACH_AR71XX_GENERIC   0
-+#define MACH_AR71XX_WP543     1       /* Compex WP543 */
-+#define MACH_AR71XX_RB_411    2       /* MikroTik RouterBOARD 411 */
-+#define MACH_AR71XX_RB_433    3       /* MikroTik RouterBOARD 433/433AH */
-+#define MACH_AR71XX_RB_450    4       /* MikroTik RouterBOARD 450 */
-+
-+/*
-  * Valid machtype for group NEC EMMA2RH
-  */
- #define  MACH_NEC_MARKEINS    0       /* NEC EMMA2RH Mark-eins        */
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -21,6 +21,24 @@
- config MACH_ALCHEMY
-       bool "Alchemy processor based machines"
-+config ATHEROS_AR71XX
-+      bool "Atheros AR71xx based boards"
-+      select CEVT_R4K
-+      select CSRC_R4K
-+      select DMA_NONCOHERENT
-+      select HW_HAS_PCI
-+      select IRQ_CPU
-+      select GENERIC_GPIO
-+      select HAVE_GPIO_LIB
-+      select SYS_HAS_CPU_MIPS32_R1
-+      select SYS_HAS_CPU_MIPS32_R2
-+      select SYS_SUPPORTS_32BIT_KERNEL
-+      select SYS_SUPPORTS_BIG_ENDIAN
-+      select SYS_HAS_EARLY_PRINTK
-+      select MIPS_MACHINE
-+      help
-+        Support for Atheros AR71xx based boards.
-+
- config BASLER_EXCITE
-       bool "Basler eXcite smart camera"
-       select CEVT_R4K
diff --git a/target/linux/ar71xx/patches/002-ar71xx_pci.patch b/target/linux/ar71xx/patches/002-ar71xx_pci.patch
deleted file mode 100644 (file)
index 8ae604a..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/mips/pci/Makefile
-+++ b/arch/mips/pci/Makefile
-@@ -15,6 +15,7 @@
- obj-$(CONFIG_PCI_VR41XX)      += ops-vr41xx.o pci-vr41xx.o
- obj-$(CONFIG_NEC_CMBVR4133)   += fixup-vr4133.o
- obj-$(CONFIG_MARKEINS)                += ops-emma2rh.o pci-emma2rh.o fixup-emma2rh.o
-+obj-$(CONFIG_ATHEROS_AR71XX)  += pci-ar71xx.o
- #
- # These are still pretty much in the old state, watch, go blind.
diff --git a/target/linux/ar71xx/patches/003-ar71xx_usb_host.patch b/target/linux/ar71xx/patches/003-ar71xx_usb_host.patch
deleted file mode 100644 (file)
index 60c0d1e..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/drivers/usb/host/Kconfig
-+++ b/drivers/usb/host/Kconfig
-@@ -260,3 +260,15 @@
-         To compile this driver as a module, choose M here: the
-         module will be called r8a66597-hcd.
-+config USB_OHCI_AR71XX
-+      bool "USB OHCI support for Atheros AR71xx"
-+      depends on ATHEROS_AR71XX && USB_OHCI_HCD
-+      help
-+        Support for Atheros AR71xx built-in OHCI controller
-+
-+config USB_EHCI_AR71XX
-+      bool "USB EHCI support for AR71xx"
-+      depends on ATHEROS_AR71XX && USB_EHCI_HCD
-+      help
-+        Support for Atheros AR71xx built-in EHCI controller
-+
---- a/drivers/usb/host/ehci-hcd.c
-+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1043,6 +1043,11 @@
- #define       PLATFORM_DRIVER         ixp4xx_ehci_driver
- #endif
-+#ifdef CONFIG_USB_EHCI_AR71XX
-+#include "ehci-ar71xx.c"
-+#define PLATFORM_DRIVER               ehci_hcd_ar71xx_driver
-+#endif
-+
- #if !defined(PCI_DRIVER) && !defined(PLATFORM_DRIVER) && \
-     !defined(PS3_SYSTEM_BUS_DRIVER) && !defined(OF_PLATFORM_DRIVER)
- #error "missing bus glue for ehci-hcd"
---- a/drivers/usb/host/ohci.h
-+++ b/drivers/usb/host/ohci.h
-@@ -538,6 +538,11 @@
- #define writel_be(val, addr)  out_be32((__force unsigned *)addr, val)
- #endif
-+#if defined(CONFIG_ATHEROS_AR71XX)
-+#define readl_be(addr)                __raw_readl(addr)
-+#define writel_be(val, addr)  __raw_writel(addr, val)
-+#endif
-+
- static inline unsigned int _ohci_readl (const struct ohci_hcd *ohci,
-                                       __hc32 __iomem * regs)
- {
---- a/drivers/usb/host/ohci-hcd.c
-+++ b/drivers/usb/host/ohci-hcd.c
-@@ -1057,6 +1057,11 @@
- #define SM501_OHCI_DRIVER     ohci_hcd_sm501_driver
- #endif
-+#ifdef CONFIG_USB_OHCI_AR71XX
-+#include "ohci-ar71xx.c"
-+#define PLATFORM_DRIVER               ohci_hcd_ar71xx_driver
-+#endif
-+
- #if   !defined(PCI_DRIVER) &&         \
-       !defined(PLATFORM_DRIVER) &&    \
-       !defined(OF_PLATFORM_DRIVER) && \
diff --git a/target/linux/ar71xx/patches/004-ar71xx_spi_controller.patch b/target/linux/ar71xx/patches/004-ar71xx_spi_controller.patch
deleted file mode 100644 (file)
index b2d11ff..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -52,6 +52,13 @@
- comment "SPI Master Controller Drivers"
-       depends on SPI_MASTER
-+config SPI_AR71XX
-+      tristate "Atheros AR71xx SPI Controller"
-+      depends on SPI_MASTER && ATHEROS_AR71XX
-+      select SPI_BITBANG
-+      help
-+        This is the SPI contoller driver for Atheros AR71xx.
-+
- config SPI_ATMEL
-       tristate "Atmel SPI Controller"
-       depends on (ARCH_AT91 || AVR32) && SPI_MASTER
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
-@@ -11,6 +11,7 @@
- obj-$(CONFIG_SPI_MASTER)              += spi.o
- # SPI master controller drivers (bus)
-+obj-$(CONFIG_SPI_AR71XX)              += ar71xx_spi.o
- obj-$(CONFIG_SPI_ATMEL)                       += atmel_spi.o
- obj-$(CONFIG_SPI_BFIN)                        += spi_bfin5xx.o
- obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
diff --git a/target/linux/ar71xx/patches/005-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches/005-ar71xx_mac_driver.patch
deleted file mode 100644 (file)
index 4a009a9..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/drivers/net/Kconfig
-+++ b/drivers/net/Kconfig
-@@ -2067,6 +2067,8 @@
-         The safe and default value for this is N.
-+source drivers/net/ag71xx/Kconfig
-+
- config DL2K
-       tristate "DL2000/TC902x-based Gigabit Ethernet support"
-       depends on PCI
---- a/drivers/net/Makefile
-+++ b/drivers/net/Makefile
-@@ -2,6 +2,7 @@
- # Makefile for the Linux network (ethercard) device drivers.
- #
-+obj-$(CONFIG_AG71XX) += ag71xx/
- obj-$(CONFIG_E1000) += e1000/
- obj-$(CONFIG_E1000E) += e1000e/
- obj-$(CONFIG_IBM_EMAC) += ibm_emac/
diff --git a/target/linux/ar71xx/patches/100-mtd_pm25lv_flash_support.patch b/target/linux/ar71xx/patches/100-mtd_pm25lv_flash_support.patch
deleted file mode 100644 (file)
index fb763af..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/drivers/mtd/devices/m25p80.c
-+++ b/drivers/mtd/devices/m25p80.c
-@@ -441,6 +441,10 @@
-       { "at26df161a", 0x1f4601, 64 * 1024, 32, SECT_4K, },
-       { "at26df321",  0x1f4701, 64 * 1024, 64, SECT_4K, },
-+      /* PMC -- pm25x "blocks" are 32K, sectors are 4K */
-+      { "pm25lv512",         0, 32 * 1024, 2, SECT_4K },
-+      { "pm25lv010",         0, 32 * 1024, 4, SECT_4K },
-+
-       /* Spansion -- single (large) sector size only, at least
-        * for the chips listed here (without boot sectors).
-        */
diff --git a/target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch
deleted file mode 100644 (file)
index 9b69eca..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -76,6 +76,11 @@
-       ---help---
-         Currently supports the Marvell 88E6060 switch.
-+config MICREL_PHY
-+      tristate "Drivers for Micrel/Kendin PHYs"
-+      ---help---
-+        Currently has a driver for the KSZ8041
-+
- config FIXED_PHY
-       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
-       depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -15,5 +15,6 @@
- obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
- obj-$(CONFIG_REALTEK_PHY)     += realtek.o
-+obj-$(CONFIG_MICREL_PHY)      += micrel.o
- obj-$(CONFIG_FIXED_PHY)               += fixed.o
- obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o
diff --git a/target/linux/ar71xx/patches/140-redboot_partition_scan.patch b/target/linux/ar71xx/patches/140-redboot_partition_scan.patch
deleted file mode 100644 (file)
index baf8026..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
---- a/drivers/mtd/redboot.c
-+++ b/drivers/mtd/redboot.c
-@@ -59,31 +59,32 @@
-       static char nullstring[] = "unallocated";
- #endif
-+      buf = vmalloc(master->erasesize);
-+      if (!buf)
-+              return -ENOMEM;
-+
-+ restart:
-       if ( directory < 0 ) {
-               offset = master->size + directory * master->erasesize;
--              while (master->block_isbad && 
-+              while (master->block_isbad &&
-                      master->block_isbad(master, offset)) {
-                       if (!offset) {
-                       nogood:
-                               printk(KERN_NOTICE "Failed to find a non-bad block to check for RedBoot partition table\n");
-+                              vfree(buf);
-                               return -EIO;
-                       }
-                       offset -= master->erasesize;
-               }
-       } else {
-               offset = directory * master->erasesize;
--              while (master->block_isbad && 
-+              while (master->block_isbad &&
-                      master->block_isbad(master, offset)) {
-                       offset += master->erasesize;
-                       if (offset == master->size)
-                               goto nogood;
-               }
-       }
--      buf = vmalloc(master->erasesize);
--
--      if (!buf)
--              return -ENOMEM;
--
-       printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
-              master->name, offset);
-@@ -155,6 +156,11 @@
-       }
-       if (i == numslots) {
-               /* Didn't find it */
-+              if (offset + master->erasesize < master->size) {
-+                      /* not at the end of the flash yet, maybe next block :) */
-+                      directory++;
-+                      goto restart;
-+              }
-               printk(KERN_NOTICE "No RedBoot partition table detected in %s\n",
-                      master->name);
-               ret = 0;
diff --git a/target/linux/ar71xx/patches/200-rb4xx_nand_driver.patch b/target/linux/ar71xx/patches/200-rb4xx_nand_driver.patch
deleted file mode 100644 (file)
index d9f6716..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/drivers/mtd/nand/Kconfig
-+++ b/drivers/mtd/nand/Kconfig
-@@ -330,4 +330,8 @@
-         Enabling this option will enable you to use this to control
-         external NAND devices.
-+config MTD_NAND_RB4XX
-+      tristate "NAND flash driver for RouterBoard 4xx series"
-+      depends on MTD_NAND && ATHEROS_AR71XX
-+
- endif # MTD_NAND
---- a/drivers/mtd/nand/Makefile
-+++ b/drivers/mtd/nand/Makefile
-@@ -28,6 +28,7 @@
- obj-$(CONFIG_MTD_NAND_CM_X270)                += cmx270_nand.o
- obj-$(CONFIG_MTD_NAND_BASLER_EXCITE)  += excite_nandflash.o
- obj-$(CONFIG_MTD_NAND_PLATFORM)               += plat_nand.o
-+obj-$(CONFIG_MTD_NAND_RB4XX)          += rb4xx_nand.o
- obj-$(CONFIG_MTD_ALAUDA)              += alauda.o
- obj-$(CONFIG_MTD_NAND_PASEMI)         += pasemi_nand.o
- obj-$(CONFIG_MTD_NAND_ORION)          += orion_nand.o
diff --git a/target/linux/ar71xx/patches/900-mips_multi_machine_support.patch b/target/linux/ar71xx/patches/900-mips_multi_machine_support.patch
deleted file mode 100644 (file)
index 1d9a601..0000000
+++ /dev/null
@@ -1,143 +0,0 @@
---- /dev/null
-+++ b/include/asm-mips/mips_machine.h
-@@ -0,0 +1,49 @@
-+/*
-+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
-+ *
-+ *  This program is free software; you can redistribute it and/or modify it
-+ *  under the terms of the GNU General Public License version 2 as published
-+ *  by the Free Software Foundation.
-+ *
-+ */
-+
-+#ifndef __ASM_MIPS_MACHINE_H
-+#define __ASM_MIPS_MACHINE_H
-+
-+#include <linux/init.h>
-+#include <linux/list.h>
-+
-+#include <asm/bootinfo.h>
-+
-+#define MIPS_MACHINE_NAME_LEN 64
-+
-+struct mips_machine {
-+      unsigned long           mach_type;
-+      void                    (*mach_setup)(void);
-+      unsigned char           mach_name[MIPS_MACHINE_NAME_LEN];
-+      struct list_head        list;
-+};
-+
-+void mips_machine_register(struct mips_machine *) __init;
-+void mips_machine_setup(void) __init;
-+
-+extern unsigned char mips_machine_name[MIPS_MACHINE_NAME_LEN];
-+
-+#define MIPS_MACHINE(_type, _name, _setup)                    \
-+static struct mips_machine machine_##_type __initdata =               \
-+{                                                             \
-+      .mach_type      = _type,                                \
-+      .mach_name      = _name,                                \
-+      .mach_setup     = _setup,                               \
-+};                                                            \
-+                                                              \
-+static int __init register_machine_##_type(void)              \
-+{                                                             \
-+      mips_machine_register(&machine_##_type);                \
-+      return 0;                                               \
-+}                                                             \
-+                                                              \
-+pure_initcall(register_machine_##_type)
-+
-+#endif /* __ASM_MIPS_MACHINE_H */
-+
---- /dev/null
-+++ b/arch/mips/kernel/mips_machine.c
-@@ -0,0 +1,58 @@
-+/*
-+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
-+ *
-+ *  This program is free software; you can redistribute it and/or modify it
-+ *  under the terms of the GNU General Public License version 2 as published
-+ *  by the Free Software Foundation.
-+ *
-+ */
-+
-+#include <asm/mips_machine.h>
-+#include <asm/bootinfo.h>
-+
-+static struct list_head mips_machines __initdata =
-+              LIST_HEAD_INIT(mips_machines);
-+
-+unsigned char mips_machine_name[MIPS_MACHINE_NAME_LEN] = "Unknown";
-+
-+static struct mips_machine * __init mips_machine_find(unsigned long machtype)
-+{
-+      struct list_head *this;
-+
-+      list_for_each(this, &mips_machines) {
-+              struct mips_machine *mach;
-+
-+              mach = list_entry(this, struct mips_machine, list);
-+              if (mach->mach_type == machtype)
-+                      return mach;
-+      }
-+
-+      return NULL;
-+}
-+
-+void __init mips_machine_register(struct mips_machine *mach)
-+{
-+      list_add_tail(&mach->list, &mips_machines);
-+}
-+
-+void __init mips_machine_setup(void)
-+{
-+      struct mips_machine *mach;
-+
-+      mach = mips_machine_find(mips_machtype);
-+      if (!mach) {
-+              printk(KERN_ALERT "MIPS: no machine registered for "
-+                      "machtype %lu\n", mips_machtype);
-+              return;
-+      }
-+
-+      if (mach->mach_name[0])
-+              strncpy(mips_machine_name, mach->mach_name,
-+                      MIPS_MACHINE_NAME_LEN);
-+
-+      printk(KERN_INFO "MIPS: machine is %s\n", mips_machine_name);
-+
-+      if (mach->mach_setup)
-+              mach->mach_setup();
-+}
-+
---- a/arch/mips/kernel/Makefile
-+++ b/arch/mips/kernel/Makefile
-@@ -79,6 +79,7 @@
- obj-$(CONFIG_KEXEC)           += machine_kexec.o relocate_kernel.o
- obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
-+obj-$(CONFIG_MIPS_MACHINE)    += mips_machine.o
- CFLAGS_cpu-bugs64.o   = $(shell if $(CC) $(KBUILD_CFLAGS) -Wa,-mdaddi -c -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-DHAVE_AS_SET_DADDI"; fi)
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -701,6 +701,7 @@
- endchoice
-+source "arch/mips/ar71xx/Kconfig"
- source "arch/mips/au1000/Kconfig"
- source "arch/mips/basler/excite/Kconfig"
- source "arch/mips/jazz/Kconfig"
-@@ -858,6 +859,9 @@
- config MIPS_DISABLE_OBSOLETE_IDE
-       bool
-+config MIPS_MACHINE
-+      def_bool n
-+
- config NO_IOPORT
-       def_bool n
diff --git a/target/linux/ar71xx/patches/901-get_c0_compare_irq_function.patch b/target/linux/ar71xx/patches/901-get_c0_compare_irq_function.patch
deleted file mode 100644 (file)
index 0cc114d..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/arch/mips/kernel/traps.c
-+++ b/arch/mips/kernel/traps.c
-@@ -42,6 +42,7 @@
- #include <asm/mmu_context.h>
- #include <asm/types.h>
- #include <asm/stacktrace.h>
-+#include <asm/time.h>
- extern asmlinkage void handle_int(void);
- extern asmlinkage void handle_tlbm(void);
-@@ -1379,6 +1380,8 @@
-        */
-       if (cpu_has_mips_r2) {
-               cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
-+              if (get_c0_compare_irq)
-+                      cp0_compare_irq = get_c0_compare_irq();
-               cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
-               if (cp0_perfcount_irq == cp0_compare_irq)
-                       cp0_perfcount_irq = -1;
---- a/include/asm-mips/time.h
-+++ b/include/asm-mips/time.h
-@@ -53,6 +53,7 @@
- #ifdef CONFIG_CEVT_R4K
- extern int mips_clockevent_init(void);
- extern unsigned int __weak get_c0_compare_int(void);
-+extern unsigned int __weak get_c0_compare_irq(void);
- #else
- static inline int mips_clockevent_init(void)
- {
diff --git a/target/linux/ar71xx/patches/902-mips_clocksource_init_war.patch b/target/linux/ar71xx/patches/902-mips_clocksource_init_war.patch
deleted file mode 100644 (file)
index 0f1bc95..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/include/asm-mips/hazards.h
-+++ b/include/asm-mips/hazards.h
-@@ -64,7 +64,7 @@
-       _ehb
-       )
- ASMMACRO(back_to_back_c0_hazard,
--       _ehb
-+       _ssnop; _ssnop; _ssnop; _ehb
-       )
- /*
-  * gcc has a tradition of misscompiling the previous construct using the
---- a/arch/mips/kernel/cevt-r4k.c
-+++ b/arch/mips/kernel/cevt-r4k.c
-@@ -187,7 +187,7 @@
-        */
-       if (c0_compare_int_pending()) {
-               write_c0_compare(read_c0_count());
--              irq_disable_hazard();
-+              back_to_back_c0_hazard();               
-               if (c0_compare_int_pending())
-                       return 0;
-       }
-@@ -196,7 +196,7 @@
-               cnt = read_c0_count();
-               cnt += delta;
-               write_c0_compare(cnt);
--              irq_disable_hazard();
-+              back_to_back_c0_hazard();               
-               if ((int)(read_c0_count() - cnt) < 0)
-                   break;
-               /* increase delta if the timer was already expired */
-@@ -205,11 +205,12 @@
-       while ((int)(read_c0_count() - cnt) <= 0)
-               ;       /* Wait for expiry  */
-+      back_to_back_c0_hazard();
-       if (!c0_compare_int_pending())
-               return 0;
-       write_c0_compare(read_c0_count());
--      irq_disable_hazard();
-+      back_to_back_c0_hazard();               
-       if (c0_compare_int_pending())
-               return 0;