[packages] miniupnpd: Updated miniupnpd to 1.5.20110302.
authorDaniel Dickinson <crazycshore@gmail.com>
Sun, 6 Mar 2011 14:38:59 +0000 (14:38 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Sun, 6 Mar 2011 14:38:59 +0000 (14:38 +0000)
Changed from using static config.h.openwrt from upstream tarball to using genconfig.sh from upstream config (with patches to genconfig.sh to generate the correction config.h for openwrt).  closes: 8934

SVN-Revision: 25887

net/miniupnpd/Makefile
net/miniupnpd/patches/010-genconfigsh_for_openwrt.patch [new file with mode: 0644]

index 8dd08a4498a499d82c844af5257b84ce31b3aa17..66a43a5346eb53e559b18c6c2844a3cb745ee84c 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=1.5
-PKG_RELEASE:=6
-PKG_MD5SUM:=063f03a2a8363b9d4cb0f73b20b8dfce
+PKG_VERSION:=1.5.20110302
+PKG_RELEASE:=1
+PKG_MD5SUM:=9c2906a2f87d9b9504e4fc09488afe41
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -32,7 +32,7 @@ define Package/miniupnpd/conffiles
 endef
 
 define Build/Compile
-       ln -sf $(PKG_BUILD_DIR)/config.h.openwrt $(PKG_BUILD_DIR)/config.h
+       echo "OpenWRT/$(OPENWRTVERSION)" | tr \(\)\  _ >$(PKG_BUILD_DIR)/os.openwrt
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
                $(TARGET_CONFIGURE_OPTS) \
                STAGING_DIR="$(STAGING_DIR)" \
diff --git a/net/miniupnpd/patches/010-genconfigsh_for_openwrt.patch b/net/miniupnpd/patches/010-genconfigsh_for_openwrt.patch
new file mode 100644 (file)
index 0000000..d8b6c0a
--- /dev/null
@@ -0,0 +1,104 @@
+--- a/Makefile.openwrt
++++ b/Makefile.openwrt
+@@ -59,8 +59,8 @@ depend:      config.h
+       $(ALLOBJS:.o=.c) $(TESTUPNPDESCGENOBJS:.o=.c) \
+       2>/dev/null
+-config.h:     config.h.openwrt
+-      $(CP) $< $@
++config.h:     genconfig.sh
++      ./genconfig.sh
+ # DO NOT DELETE
+--- a/genconfig.sh
++++ b/genconfig.sh
+@@ -28,6 +28,12 @@ if [ -f /etc/platform ]; then
+       fi
+ fi
++# OpenWRT special case
++if [ -f ./os.openwrt ]; then
++      OS_NAME=OpenWRT
++      OS_VERSION=$(cat ./os.openwrt)
++fi
++
+ ${RM} ${CONFIGFILE}
+ echo "/* MiniUPnP Project" >> ${CONFIGFILE}
+@@ -176,6 +182,11 @@ case $OS_NAME in
+               echo "#define USE_NETFILTER 1" >> ${CONFIGFILE}
+               FW=netfilter
+               ;;
++      OpenWRT)
++              OS_URL=http://www.openwrt.org/
++              echo "#define USE_NETFILTER 1" >> ${CONFIGFILE}
++              FW=netfilter
++              ;;
+       Darwin)
+               echo "#define USE_IPFW 1" >> ${CONFIGFILE}
+               FW=ipfw
+--- a/config.h.openwrt
++++ /dev/null
+@@ -1,29 +0,0 @@
+-/* $Id: config.h.openwrt,v 1.4 2011/02/28 17:30:24 nanard Exp $ */
+-/* MiniUPnP Project
+- * http:///miniupnp.free.fr
+- * (c) 2006-2011 Thomas Bernard
+- */
+-#ifndef __CONFIG_H__
+-#define __CONFIG_H__
+-
+-#define MINIUPNPD_VERSION "1.5"
+-
+-#define UPNP_VERSION  "20070228"
+-#define USE_NETFILTER 1
+-#define OS_NAME       "OpenWRT"
+-/* OS/version */
+-#define OS_VERSION    "OpenWRT/kamikaze"
+-#define OS_URL        "http://openwrt.org/"
+-
+-#define LOG_MINIUPNPD LOG_DAEMON
+-
+-/* Comment the following line to disable NAT-PMP operations */
+-#define ENABLE_NATPMP
+-
+-/* Comment the following line to use home made daemonize() func instead
+- * of BSD daemon() */
+-#define USE_DAEMON
+-
+-#define ENABLE_L3F_SERVICE
+-
+-#endif
+--- /dev/null
++++ b/config.h.openwrt.old
+@@ -0,0 +1,29 @@
++/* $Id: config.h.openwrt,v 1.4 2011/02/28 17:30:24 nanard Exp $ */
++/* MiniUPnP Project
++ * http:///miniupnp.free.fr
++ * (c) 2006-2011 Thomas Bernard
++ */
++#ifndef __CONFIG_H__
++#define __CONFIG_H__
++
++#define MINIUPNPD_VERSION "1.5"
++
++#define UPNP_VERSION  "20070228"
++#define USE_NETFILTER 1
++#define OS_NAME       "OpenWRT"
++/* OS/version */
++#define OS_VERSION    "OpenWRT/kamikaze"
++#define OS_URL        "http://openwrt.org/"
++
++#define LOG_MINIUPNPD LOG_DAEMON
++
++/* Comment the following line to disable NAT-PMP operations */
++#define ENABLE_NATPMP
++
++/* Comment the following line to use home made daemonize() func instead
++ * of BSD daemon() */
++#define USE_DAEMON
++
++#define ENABLE_L3F_SERVICE
++
++#endif