[package] update st2205tool to 1.4.3 (#5731)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 21 Aug 2009 09:04:43 +0000 (09:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 21 Aug 2009 09:04:43 +0000 (09:04 +0000)
SVN-Revision: 17343

libs/st2205tool/Makefile
libs/st2205tool/patches/110-libst-makefile.patch

index 2e5e7b5304495f6ad3eaefa544576391857cd876..66a7a47727999ed868f89ea4126b2bbd564af04f 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=st2205tool
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=st2205tool
-PKG_VERSION:=1.4pre1
+PKG_VERSION:=1.4.3
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_SOURCE:=st2205tool-v$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://spritesmods.com/picframe/
-PKG_MD5SUM:=bf602227bce9c4365e5ae5e9b383d8d9
+PKG_SOURCE:=st2205tool-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.neophob.com/files/
+PKG_MD5SUM:=c87f05a5f692e869d2d050aa3d4fd6c5
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -50,7 +50,6 @@ endef
 
 define Package/st2205tool/install
        $(INSTALL_DIR) $(1)/usr/sbin
 
 define Package/st2205tool/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/{bgrep,phack,splice,hackfw.sh} $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/setpic/setpic $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libst2205/libst2205.so* $(1)/usr/lib/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/setpic/setpic $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libst2205/libst2205.so* $(1)/usr/lib/
index c83c7d98755774bebe1bdca5ef692b82e587c28d..96b95ae431b2bc16763c8ffa86222818745fc30c 100644 (file)
@@ -1,13 +1,13 @@
---- st2205tool/libst2205/Makefile.orig 2008-01-20 20:22:32.000000000 +0100
-+++ st2205tool/libst2205/Makefile      2008-04-21 07:36:56.000000000 +0200
-@@ -6,15 +6,15 @@
+--- st2205tool/libst2205/Makefile.orig 2009-08-19 17:05:54.000000000 +0200
++++ st2205tool/libst2205/Makefile      2009-08-19 17:06:27.000000000 +0200
+@@ -7,15 +7,15 @@
  all:  libst2205.so
  
  all:  libst2205.so
  
- libst2205.so:         $(OBJ) $(SRC
+ libst2205.so: $(OBJ) $(SRC) $(HEADERS
 -      ar -rv libst2205.a $(OBJ) 
 -      gcc -shared -Wl,-soname,libst2205.so.1 -o libst2205.so $(OBJ) $(LIBS)
 +      $(AR) -rv libst2205.a $(OBJ) 
 -      ar -rv libst2205.a $(OBJ) 
 -      gcc -shared -Wl,-soname,libst2205.so.1 -o libst2205.so $(OBJ) $(LIBS)
 +      $(AR) -rv libst2205.a $(OBJ) 
-+      $(GCC) -shared -Wl,-soname,libst2205.so -o libst2205.so $(OBJ) $(LIBS)
++      $(GCC) -shared -Wl,-soname,libst2205.so.1 -o libst2205.so $(OBJ) $(LIBS)
  
  clean:        
        rm -f $(OBJ) test *.a *.so
  
  clean:        
        rm -f $(OBJ) test *.a *.so