cleanup
authorFelix Fietkau <nbd@openwrt.org>
Thu, 19 Oct 2006 15:26:14 +0000 (15:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 19 Oct 2006 15:26:14 +0000 (15:26 +0000)
SVN-Revision: 5233

39 files changed:
admin/osiris/Makefile
libs/avahi/Makefile
libs/glib/Makefile
libs/libelf/Makefile
libs/libgphoto2/Makefile
libs/libnet-1.0.x/Makefile
libs/libnet-1.1.x/Makefile
libs/libusb/Makefile
libs/mysql/Makefile
libs/ncurses/Makefile
libs/openldap/Makefile
libs/radiusclient-ng/Makefile
libs/serdisplib/Makefile
multimedia/gphoto2/Makefile
net/chillispot/Makefile
net/click/Makefile
net/dhcp-forwarder/Makefile
net/iperf/Makefile
net/miau/Makefile
net/nfs-kernel-server/Makefile
net/ptunnel/Makefile
net/raddump/Makefile
net/rp-pppoe/Makefile
net/samba/Makefile
net/slurm/Makefile
net/squid/Makefile
net/tmsnc/Makefile
net/vncrepeater/Makefile
net/wccpd/Makefile
net/wifidog/Makefile
sound/madplay/Makefile
sound/mt-daapd/Makefile
utils/fetchmail/Makefile
utils/gnupg/Makefile
utils/mutt/Makefile
utils/rrdcollect/Makefile
utils/screen/Makefile
utils/usbutils/Makefile
utils/vim/Makefile

index 917134a7a39474cdc99605f0fd7fe5785ca42776..81a180758c61704adc91c121143e8b2f461fec5f 100644 (file)
@@ -33,14 +33,12 @@ define Package/osirisd
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-  $(call Build/Configure/Default, \
-       --with-osiris-user=root \
-       --with-root-dir=/var/lib/osiris \
-       --with-readline=no, \
-       ac_cv_openssldir="$(STAGING_DIR)/usr" \
-       ac_cv_have_accrights_in_msghdr=no \
-       ac_cv_have_control_in_msghdr=yes \
-  )
+       $(call Build/Configure/Default, \
+               --with-osiris-user=root \
+               --with-root-dir=/var/lib/osiris \
+               --with-readline=no, \
+               ac_cv_openssldir="$(STAGING_DIR)/usr" \
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
index d6ebefd83e69f11df461fccd257d383339f7fb5a..78be0e9047060c7f03bbdaad0cd37ba3bf4db809 100644 (file)
@@ -89,9 +89,6 @@ define Build/Configure
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
-               ac_cv_func_memcmp_working=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index b60f5f05a600821d1ceecf821583358d11355ff1..d96f2903dbcbfb17ddff546f929947dd28bef78b 100644 (file)
@@ -39,12 +39,6 @@ endef
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                glib_cv_sizeof_gmutex=24 \
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                glib_cv_sizeof_gmutex=24 \
-               ac_cv_sizeof_char=1 \
-               ac_cv_sizeof_short=2 \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4 \
-               ac_cv_sizeof_long_long=8 \
-               ac_cv_sizeof_void_p=4 \
                glib_cv_prog_cc_ansi_proto="no" \
                glib_cv_has__inline="yes" \
                glib_cv_has__inline__="yes" \
                glib_cv_prog_cc_ansi_proto="no" \
                glib_cv_has__inline="yes" \
                glib_cv_has__inline__="yes" \
@@ -55,7 +49,6 @@ define Build/Configure
                glib_cv_va_val_copy="yes" \
                glib_cv_rtldglobal_broken="no" \
                glib_cv_uscore="no" \
                glib_cv_va_val_copy="yes" \
                glib_cv_rtldglobal_broken="no" \
                glib_cv_uscore="no" \
-               ac_cv_func_getpwuid_r="yes" \
                glib_cv_func_pthread_mutex_trylock_posix="yes" \
                glib_cv_func_pthread_cond_timedwait_posix="yes" \
                glib_cv_sizeof_gmutex="24" \
                glib_cv_func_pthread_mutex_trylock_posix="yes" \
                glib_cv_func_pthread_cond_timedwait_posix="yes" \
                glib_cv_sizeof_gmutex="24" \
index d861b9584ef023fb68ec57ed57a8dc6504148512..faa93311015c8e0bf844d942cf8e40fa5be08093 100644 (file)
@@ -41,7 +41,6 @@ define Build/Configure
                libelf_cv_struct_elf64_ehdr=yes \
                libelf_cv_type_elf64_addr=no \
                libelf_cv_struct_elf64_rel=yes \
                libelf_cv_struct_elf64_ehdr=yes \
                libelf_cv_type_elf64_addr=no \
                libelf_cv_struct_elf64_rel=yes \
-               ac_cv_sizeof_long_long=8 \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index f0afc4314daca48e985025c9143f27a2cb5829ac..d7738d7a3c8cad057cd933fb22bc4ed750a9a15c 100644 (file)
@@ -42,11 +42,6 @@ define Package/libgphoto2-drivers
   TITLE:=Gphoto2 drivers for various cameras
 endef
 
   TITLE:=Gphoto2 drivers for various cameras
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(CONFIG_BIG_ENDIAN),y)
-  BIG_ENDIAN:=yes
-endif
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -63,8 +58,6 @@ define Build/Configure
                LIBUSB_CFLAGS="$$$$CPPFLAGS" \
                LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
                LIBS="-lltdl" \
                LIBUSB_CFLAGS="$$$$CPPFLAGS" \
                LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
                LIBS="-lltdl" \
-               ac_cv_c_gettext_without_libintl=yes \
-               ac_cv_c_bigendian=$(BIG_ENDIAN) \
        )
 endef
 
        )
 endef
 
index 9a125200cdb55397001795756f7a33e15d98104b..66814b16bd36d69df89b041e77720897825206af 100644 (file)
@@ -46,11 +46,9 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes \
-               , \
-               ac_libnet_have_pf_packet=yes \
-               ac_cv_lbl_unaligned_fail=no \
+               --with-pf_packet=yes, \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_cv_libnet_endianess=$(ENDIANESS) \
+               ac_libnet_have_pf_packet=yes \
        )
 endef
 
        )
 endef
 
index 5eb9904ac3d334c9ee47830b76447175b407e242..e67a4d60d1f0982ef4c495e9a37f7044a8d33119 100644 (file)
@@ -46,11 +46,9 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes \
-               , \
-               ac_libnet_have_pf_packet=yes \
-               ac_cv_lbl_unaligned_fail=no \
+               --with-pf_packet=yes, \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_cv_libnet_endianess=$(ENDIANESS) \
+               ac_libnet_have_pf_packet=yes \
                ac_libnet_have_packet_socket=yes \
        )
 endef
                ac_libnet_have_packet_socket=yes \
        )
 endef
index 934658c1b622703a07d12143bf1e68d704e3214b..4966c1ff4f8145e8651995a5715a611572b936d5 100644 (file)
@@ -36,7 +36,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_c_bigendian=no \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index 723492ea6a2bb5555f4cfe78ea136e96e1761364..201a555da6e2a5baab9c739a4815ba2c7d17d6f2 100644 (file)
@@ -48,10 +48,6 @@ define Build/Configure
                CXXFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CXXFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_atomic_add=yes \
-               ac_atomic_sub=yes \
-               ac_cv_sys_restartable_syscalls=yes \
-               ac_cv_conv_longlong_to_float=yes \
                mysql_cv_compress=yes \
                mysql_cv_gethostname_style=glibc2 \
                ./configure \
                mysql_cv_compress=yes \
                mysql_cv_gethostname_style=glibc2 \
                ./configure \
index a06e29a05b47e2cb2bf89e58659015021cfaffd7..2eee9cd63a370df04442620553a61f2cd88dd78b 100644 (file)
@@ -37,6 +37,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               CONFIG_SITE="" \
                ./configure \
                        --target=$(GNU_HOST_NAME) \
                        --host=$(GNU_HOST_NAME) \
                ./configure \
                        --target=$(GNU_HOST_NAME) \
                        --host=$(GNU_HOST_NAME) \
@@ -80,7 +81,6 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_linux_vers="2" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index 8702315f64f0c49cefddfe227d6b10e6515816fb..35006b28465b3c870b9e14bca7353a627ae03ca6 100644 (file)
@@ -119,7 +119,6 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
-               ac_cv_func_memcmp_clean="yes" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index 57d4b8becf8b88a160bd6feec56bd5bf8e2dfde6..9af8543cff531e48bf8f4e37c36387a783d6ee86 100644 (file)
@@ -62,7 +62,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_func_getdomainname=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index 5a4ac3e03da0b648f24bd357453611bacf658a29..41df8d29f3c6a97b474a1a8d5d415b30da2d6acc 100644 (file)
@@ -36,7 +36,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_func_malloc_0_nonnull=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index aa3fb49ca7b116a296686b56a2850946dcd16380..38b44879333887dd74e0b1e3e70c1472f3e6d5bf 100644 (file)
@@ -31,11 +31,6 @@ define Package/gphoto2
   URL:=http://www.gphoto.org/
 endef
 
   URL:=http://www.gphoto.org/
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(CONFIG_BIG_ENDIAN),y)
-  BIG_ENDIAN:=yes
-endif
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --without-libiconv-prefix \
 define Build/Configure
        $(call Build/Configure/Default, \
                --without-libiconv-prefix \
@@ -47,8 +42,6 @@ define Build/Configure
                LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
                POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                POPT_LIBS="$$$$LDFLAGS -lpopt" \
                LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
                POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                POPT_LIBS="$$$$LDFLAGS -lpopt" \
-               ac_cv_c_bigendian="$(BIG_ENDIAN)" \
-               ac_cv_func_malloc_0_nonnull=yes \
        )
 endef
 
        )
 endef
 
index e3627674b0da457c643c70c8ef420edb31a564cf..3f6238e3130bc1a42e8ad7b51e0d127f084cca98 100644 (file)
@@ -48,9 +48,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_func_setvbuf_reversed=no \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index cfa49e835431153674ae89a5a7cce049d4b4c04e..61a5a738bca084cace5f28dd1670dc955bf10e02 100644 (file)
@@ -41,13 +41,8 @@ define Package/roofnet
   URL:=http://pdos.csail.mit.edu/roofnet/
 endef
 
   URL:=http://pdos.csail.mit.edu/roofnet/
 endef
 
-CONF_OPTS= \
-               ac_cv_int64_t=no \
-               ac_cv_sizeof_off_t=4
-
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               $(CONF_OPTS) \
                ./configure; \
                cp include/click/config.h include/click/config-host.h; \
                rm -rf config.{cache,status} ; \
                ./configure; \
                cp include/click/config.h include/click/config-host.h; \
                rm -rf config.{cache,status} ; \
index ef6104d7b7763deaac090356c4a225863a4f8bb7..c4002507c8b24f1b29e3fbb415f404389a0a10ed 100644 (file)
@@ -35,7 +35,7 @@ define Package/dhcp-forwarder/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,,ac_cv_func_malloc_0_nonnull="yes")
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index 2a610d28657ed8c9429424bfaeb7ebb9ba3abf54..67a7d8401f594b1d4a65f472edf8dc52139ebab9 100644 (file)
@@ -32,14 +32,16 @@ characteristics.\\\
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
---disable-static \
---disable-rpath \
---disable-multicast \
---disable-threads,CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
-LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-LIBS="-luClibc++ -lc -lm -lgcc_s" \
-ac_cv_func_malloc_0_nonnull=yes)
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --disable-static \
+               --disable-rpath \
+               --disable-multicast \
+               --disable-threads, \
+               CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
+               LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               LIBS="-luClibc++ -lc -lm -lgcc_s" \
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
index 5b59cb0d0e58ffc7ff576459d0229939d5543421..4ecd2efcaabd52b3b5ca1345fae5755deaffa5e5 100644 (file)
@@ -34,12 +34,13 @@ for IRC-networks.\\\
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-automode \
---enable-releasenick \
---enable-uptime \
---enable-privlog \
---enable-onconnect,ac_cv_func_malloc_0_nonnull=yes \
-ac_cv_func_realloc_0_nonnull=yes)
+       $(call Build/Configure/Default, \
+               --enable-automode \
+               --enable-releasenick \
+               --enable-uptime \
+               --enable-privlog \
+               --enable-onconnect \
+       )
 endef
 
 
 endef
 
 
index b16107a99a740c8a24edaa6d6c45d6171e359da7..29f4899869aca61a9fb61956c0f3c8f1428c21d7 100644 (file)
@@ -40,10 +40,12 @@ define Package/nfs-kernel-server/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-static --enable-shared --disable-nfsv4 \
---disable-gss,ac_cv_func_malloc_0_nonnull=yes \
-ac_cv_func_memcmp_working=yes \
-ac_cv_func_setvbuf_reversed=no)
+       $(call Build/Configure/Default, \
+               --enable-static \
+               --enable-shared \
+               --disable-nfsv4 \
+               --disable-gss \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index a6dbdf9fc15a7b46abda4caf09e0c829c049bc3f..2ce40709c96cc112addb4e17ec3cf40c58b8fdb7 100644 (file)
@@ -35,7 +35,7 @@ define Package/ptunnel
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
+       $(call Build/Configure/Default,--enable-shared \
                --disable-static \
                --with-gnu-ld, \
                $(TARGET_CONFIGURE_OPTS) \
                --disable-static \
                --with-gnu-ld, \
                $(TARGET_CONFIGURE_OPTS) \
@@ -44,8 +44,8 @@ $(call Build/Configure/Default,--enable-shared \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_linux_vers=2 \
-               td_cv_buggygetaddrinfo="no")
+               td_cv_buggygetaddrinfo="no" \
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
index 11e1bb38f3f45cb80c5da4b980ef6e67e390bd2f..7ccb43c1252f44a31cc638083655dd88e05bee1c 100644 (file)
@@ -34,9 +34,7 @@ define Package/raddump
 endef
 
 define Build/Configure 
 endef
 
 define Build/Configure 
-$(call Build/Configure/Default,,ac_cv_c_bigendian=no \
-                ac_cv_func_malloc_0_nonnull=yes \
-                ac_cv_func_realloc_0_nonnull=yes)
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
index 30333ffad5c82ab0a2af3f1c6b8546e6ac399b8b..1a45af82f27658fd789e9c0b6dba685252c686db 100644 (file)
@@ -54,12 +54,6 @@ define Build/Configure
  (cd $(PKG_BUILD_DIR)/src ; rm -rf config.{cache,status}; \
                 $(TARGET_CONFIGURE_OPTS) \
                 CFLAGS="$(TARGET_CFLAGS)" \
  (cd $(PKG_BUILD_DIR)/src ; rm -rf config.{cache,status}; \
                 $(TARGET_CONFIGURE_OPTS) \
                 CFLAGS="$(TARGET_CFLAGS)" \
-                ac_cv_func_setvbuf_reversed=no \
-                ac_cv_sizeof_unsigned_short=2 \
-                ac_cv_sizeof_unsigned_int=4 \
-                ac_cv_sizeof_unsigned_long=4 \
-                ac_cv_linux_kernel_pppoe=yes \
-                ac_cv_pack_bitfields_reversed=yes \
                 ./configure \
                   --target=$(GNU_TARGET_NAME) \
                   --host=$(GNU_TARGET_NAME) \
                 ./configure \
                   --target=$(GNU_TARGET_NAME) \
                   --host=$(GNU_TARGET_NAME) \
index 613d546151fe70c1edad2ef6459318ce56245b2f..0f221846091a60e1e7b94ba0a9190730928040f1 100644 (file)
@@ -82,9 +82,6 @@ define Build/Compile
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-lgcc_s -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ac_cv_lib_cups_httpConnect=no \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-lgcc_s -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ac_cv_lib_cups_httpConnect=no \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4 \
-               ac_cv_sizeof_short=2 \
                samba_cv_FTRUNCATE_NEEDS_ROOT=no \
                samba_cv_HAVE_BROKEN_FCNTL64_LOCKS=no \
                samba_cv_HAVE_BROKEN_GETGROUPS=no \
                samba_cv_FTRUNCATE_NEEDS_ROOT=no \
                samba_cv_HAVE_BROKEN_FCNTL64_LOCKS=no \
                samba_cv_HAVE_BROKEN_GETGROUPS=no \
index 8a3b40bc946c3acb9c905312b8e344978d848f0c..5cdf4acac3e2183e2ec83ad0fd7127a7f6870e71 100644 (file)
@@ -47,7 +47,6 @@ define Build/Configure
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                LIBS="-lncurses" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                LIBS="-lncurses" \
-               ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_lib_ncurses_use_default_colors=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                ac_cv_lib_ncurses_use_default_colors=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
index 7384d1266156449b2cfe44b5d133db7270f8651d..f762b71c6cf992f61c27ab20be227ddad7317180 100644 (file)
@@ -138,26 +138,7 @@ define Build/Configure
                --enable-ntlm-auth-helpers="fakeauth SMB winbind" \
                --enable-digest-auth-helpers="password" \
                --enable-external-acl-helpers="ip_user unix_group winbind_group" \
                --enable-ntlm-auth-helpers="fakeauth SMB winbind" \
                --enable-digest-auth-helpers="password" \
                --enable-external-acl-helpers="ip_user unix_group winbind_group" \
-               , \
-               ac_cv_sizeof_void_p=4 \
-               ac_cv_sizeof_short=2 \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4 \
-               ac_cv_sizeof_long_long=8 \
-               ac_cv_sizeof___int64=0 \
-               ac_cv_sizeof_int16_t=2 \
-               ac_cv_sizeof_uint16_t=2 \
-               ac_cv_sizeof_u_int16_t=2 \
-               ac_cv_sizeof_int32_t=4 \
-               ac_cv_sizeof_uint32_t=4 \
-               ac_cv_sizeof_u_int32_t=4 \
-               ac_cv_sizeof_int64_t=8 \
-               ac_cv_sizeof_uint64_t=8 \
-               ac_cv_sizeof_u_int64_t=8 \
-               ac_cv_func_setresuid=no \
-               ac_cv_func_va_copy=no \
-               ac_cv_func___va_copy=no \
-        )
+       )
 endef
        
 define Build/Compile   
 endef
        
 define Build/Compile   
index 3fced852bb13f878e9e4b3a7b7e3e28dce875725..73bafe79b70dc51aed129f7bf748b9c28b6e0ad6 100644 (file)
@@ -31,17 +31,19 @@ define Package/tmsnc
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--with-libiconv-prefix=$(STAGING_DIR)/usr \
-                  --with-openssl="$(STAGING_DIR)/usr" \
-                  --with-ncurses="$(STAGING_DIR)/usr" \
-                  --with-gnu-ld, ac_cv_func_malloc_0_nonnull=yes \
-                 ac_cv_func_realloc_0_nonnull=yes)
+       $(call Build/Configure/Default, \
+               --with-libiconv-prefix=$(STAGING_DIR)/usr \
+               --with-openssl="$(STAGING_DIR)/usr" \
+               --with-ncurses="$(STAGING_DIR)/usr" \
+               --with-gnu-ld \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
+       $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CFLAGS="$(TARGET_CFLAGS)" \
-               install)
+               install \
+       )
        rm -rf $(PKG_INSTALL_DIR)/usr/man
 endef
 
        rm -rf $(PKG_INSTALL_DIR)/usr/man
 endef
 
index ead836f3813b5a601fdb3cdb236ca06b23ac8018..e221c1ad07d42068c6710e53aa6195d53e993bdf 100644 (file)
@@ -42,7 +42,8 @@ endef
 
 define Build/Compile
 $(call Build/Compile/Default, \
 
 define Build/Compile
 $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
+               STAGING_DIR="$(STAGING_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                repeater)
 endef
                DESTDIR="$(PKG_INSTALL_DIR)" \
                repeater)
 endef
index 62ae7c0806b4007ceda485f6555c4c766cdf5c77..c1c8f45448118d012f4f3289ffdeeba096992775 100644 (file)
@@ -34,10 +34,12 @@ define Package/wccpd
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                        --enable-static \
-                        --disable-rpath \
-                        --with-gnu-ld,ac_cv_func_setpgrp_void=yes)
+       $(call Build/Configure/Default,
+               --enable-shared \
+               --enable-static \
+               --disable-rpath \
+               --with-gnu-ld \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index 45e042141d56aa721db9bfbe3c1970964d7f4b90..a538e8fa3866bf2aeb6ec5f7dc632e671f169023 100644 (file)
@@ -39,9 +39,7 @@ define Package/wifidog/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,,ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_func_setvbuf_reversed=no)
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index c446727246b0dd541fedf35f691d925aae1f5583..401aad038374586b59d00ebb2d941a0dba1eb9bf 100644 (file)
@@ -35,19 +35,19 @@ full support for ID3 tags.\\\
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
---disable-static \
---with-gnu-ld \
---disable-rpath \
---disable-debugging \
---disable-profiling \
---disable-experimental \
---without-libiconv-prefix \
---without-libintl-prefix \
---without-alsa \
---without-esd,LIBS="-lz" \
-ac_cv_linux_vers=2 \
-td_cv_buggygetaddrinfo="no")
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --disable-static \
+               --with-gnu-ld \
+               --disable-rpath \
+               --disable-debugging \
+               --disable-profiling \
+               --disable-experimental \
+               --without-libiconv-prefix \
+               --without-libintl-prefix \
+               --without-alsa \
+               --without-esd,LIBS="-lz" \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index c6be213846230fae12934fcdad5b04aa2f1a936b..23ad6f313bda038002b9140d02c88934ff8178a7 100644 (file)
@@ -37,16 +37,18 @@ define Package/mt-daapd/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                        --disable-static \
-                        --enable-mdns \
-                        --enable-howl \
-                        --with-id3tag="$(STAGING_DIR)/usr" \
-                        --with-gdbm-includes="$(STAGING_DIR)/usr/include" \
-                        --with-gdbm-libs="$(STAGING_DIR)/usr/lib" \
-                        --with-howl-includes="$(STAGING_DIR)/usr/include/howl" \
-                        --with-howl-libs="$(STAGING_DIR)/usr/lib" \
-                        --without-static-libs,ac_cv_func_setpgrp_void=yes)
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --disable-static \
+               --enable-mdns \
+               --enable-howl \
+               --with-id3tag="$(STAGING_DIR)/usr" \
+               --with-gdbm-includes="$(STAGING_DIR)/usr/include" \
+               --with-gdbm-libs="$(STAGING_DIR)/usr/lib" \
+               --with-howl-includes="$(STAGING_DIR)/usr/include/howl" \
+               --with-howl-libs="$(STAGING_DIR)/usr/lib" \
+               --without-static-libs \
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
index e541e819793debb22d2d11f3e91d0bc9dd6d5295..048fc3e5c376739f0fe32d5837080ab1093c4965 100644 (file)
@@ -32,12 +32,11 @@ define Package/fetchmail
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-fallback=procmail --without-hesiod,ac_cv_c_bigendian=no \
-ac_cv_sizeof_off_t=8 \
-ac_cv_sizeof_int=4 \
-ac_cv_sizeof_long=4 \
-ac_cv_path_procmail=/usr/sbin/procmail \
-)
+       $(call Build/Configure/Default, \
+               --enable-fallback=procmail \
+               --without-hesiod, \
+               ac_cv_path_procmail=/usr/sbin/procmail \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index 43b6035c5a55e1cacc2cccf4cb16a42d447435cc..970be4ef613723a9d523eb64bd78559be47e327e 100644 (file)
@@ -36,8 +36,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_c_bigendian=no \
-               ac_cv_sizeof_off_t=8 \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index f54b7393f182e6cf85058d033aaff61333d0e65c..87c0b87de8fbc5d8d93f286899eff49e9365609f 100644 (file)
@@ -31,14 +31,13 @@ define Package/mutt
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/. \
+       $(call Build/Configure/Default, \
+               --includedir=$(PKG_BUILD_DIR)/. \
                --oldincludedir=$(PKG_BUILD_DIR)/. \
                --enable-pop \
                --enable-imap \
                --oldincludedir=$(PKG_BUILD_DIR)/. \
                --enable-pop \
                --enable-imap \
-               --with-ssl,ac_cv_c_bigendian=no \
-               ac_cv_sizeof_off_t=8 \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4)
+               --with-ssl \
+       )
 endef
 
 define Package/mutt/install
 endef
 
 define Package/mutt/install
index a38d07d740f6c07204aa302f09a11852dab52db7..519d84d2c523058c929251a33e91cd9bc15df0f0 100644 (file)
@@ -59,20 +59,22 @@ define Package/rrdcollect-example/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                        --disable-static \
-                        --disable-rpath \
-                        --with-gnu-ld \
-                        --enable-exec \
-                        --without-rrdtool \
-                        --with-librrd \
-                        --without-libpcre \
-                        --without-libpcap, CFLAGS="$(TARGET_CFLAGS) -DSOCKET_COMM" \
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --disable-static \
+               --disable-rpath \
+               --with-gnu-ld \
+               --enable-exec \
+               --without-rrdtool \
+               --with-librrd \
+               --without-libpcre \
+               --without-libpcap, \
+               CFLAGS="$(TARGET_CFLAGS) -DSOCKET_COMM" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                LIBS="$(RRDTOOL_LIBS) -lz" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                LIBS="$(RRDTOOL_LIBS) -lz" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               ac_cv_func_malloc_0_nonnull=yes)
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
index 3dd0bfbcf7cd5b4616bce824ab236a7ed83fd103..6b1b5ac969f372c28c72730fe9c87f8f0ef80d87 100644 (file)
@@ -35,7 +35,6 @@ endef
 define Build/Configure 
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
 define Build/Configure 
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               $(foreach flag,rename fchmod fchown strerror lstat _exit utimes vsnprintf getcwd setlocale strftime,ac_cv_func_$(flag)=yes ) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
index 28f44fd467ac4115566c53ca85e4c7626e6f5b0c..408788754c47742ee217e4b41f510050245e9399 100644 (file)
@@ -37,7 +37,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_func_malloc_0_nonnull=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index aa6f526f61b4329e4abf77a6810bd46d77a0e266..df3a8778f1c8f43419199662242f8cca7d692c98 100644 (file)
@@ -31,21 +31,21 @@ define Package/vim
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-min-features \
+       $(call Build/Configure/Default, \
+                       --enable-min-features \
                        --disable-gui \
                        --without-x \
                        --disable-multibyte \
                        --disable-cscope \
                        --disable-gpm \
                        --disable-gui \
                        --without-x \
                        --disable-multibyte \
                        --disable-cscope \
                        --disable-gpm \
-                       --with-tlib=ncurses,ac_cv_c_bigendian=no \
-                       ac_cv_sizeof_off_t=8 \
-                       ac_cv_sizeof_int=4)
+                       --with-tlib=ncurses \
+       )
 endef
 
 define Package/vim/install     
        mkdir -p $(1)/usr/bin
 endef
 
 define Package/vim/install     
        mkdir -p $(1)/usr/bin
-       mkdir -p $(1)//usr/share/vim
-       $(CP) ./files/vimrc $(1)//usr/share/vim
+       mkdir -p $(1)/usr/share/vim
+       $(CP) ./files/vimrc $(1)/usr/share/vim
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef