[8.09] merge r17801
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 30 Sep 2009 16:08:03 +0000 (16:08 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 30 Sep 2009 16:08:03 +0000 (16:08 +0000)
SVN-Revision: 17802

package/ppp/Makefile
package/ppp/files/etc/ppp/ip-up

index 1c9ce14d6174eb4caaaa85d8ea559b3c4c1475cf..44fc13766c3d8aff14dedd54f2b12b0dea41dd33 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.3
-PKG_RELEASE:=11.2
+PKG_RELEASE:=11.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 46c8d377001b02ec99a997e58d95ad78bb51c7a4..ecdd00b1c4d15d25af8b2e3760cf219c3b99d091 100755 (executable)
@@ -13,6 +13,9 @@ export PPP_IFACE PPP_TTY PPP_SPEED PPP_LOCAL PPP_REMOTE PPP_IPPARAM
        uci_set_state network "$PPP_IPPARAM" unit "$PPP_UNIT"
        uci_set_state network "$PPP_IPPARAM" ipaddr "$PPP_LOCAL"
        uci_set_state network "$PPP_IPPARAM" gateway "$PPP_REMOTE"
+
+       local dns="$DNS1${DNS2:+ $DNS2}"
+       [ -n "$dns" ] && uci_set_state network "$PPP_IPPARAM" dns "$dns"
 }
 [ -z "$PPP_IPPARAM" ] || env -i ACTION="ifup" INTERFACE="$PPP_IPPARAM" DEVICE="$PPP_IFACE" PROTO=ppp /sbin/hotplug-call "iface"