sdk: predefine kernel version magic
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Sep 2014 10:25:47 +0000 (10:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Sep 2014 10:25:47 +0000 (10:25 +0000)
Kernel modules which are built using the SDK do not have access
to the .vermagic file in the Linux build dir, therefore the
generated .ipk metadata depends on kernel versions like
'3.10.49-1-unknown' which are not satisfiable by the kernel
meta package in the image.

Fix this problem by substituting 'unknown' with the current
version magic in include/kernel.mk when packing the SDK.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 42590

target/sdk/Makefile

index a2cd3a5ab082ee166dbcad907375d987b51ab98e..1c696d5ac451dc18ed761ae2675014f8fb9ded29 100644 (file)
@@ -108,6 +108,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        cat $(TOPDIR)/feeds.conf.default \
                >> $(SDK_BUILD_DIR)/feeds.conf.default
        $(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(SDK_BUILD_DIR)/include/version.mk
+       $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(SDK_BUILD_DIR)/include/kernel.mk
        find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
        find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
        find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf