update monit to new upstream release (v4.6),
authorNicolas Thill <nico@openwrt.org>
Thu, 20 Oct 2005 09:09:55 +0000 (09:09 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 20 Oct 2005 09:09:55 +0000 (09:09 +0000)
split in 2 packages (w/ and w/o ssl support),
add a restart command to init-script.

SVN-Revision: 2193

openwrt/package/Makefile
openwrt/package/monit/Config.in
openwrt/package/monit/Makefile
openwrt/package/monit/files/monit.init
openwrt/package/monit/ipkg/monit-nossl.conffiles [new file with mode: 0644]
openwrt/package/monit/ipkg/monit-nossl.control [new file with mode: 0644]
openwrt/package/monit/ipkg/monit.control

index caa5c91b383f7ccf71ada6c27871513936efa441..55fb1e1077d9e18a2463e9ab436d3a7dd32ace42 100644 (file)
@@ -110,7 +110,7 @@ package-$(BR2_PACKAGE_MICROCOM) += microcom
 package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_COMPILE_MINI_HTTPD) += mini_httpd
 package-$(BR2_PACKAGE_MINI_SENDMAIL) += mini_sendmail
-package-$(BR2_PACKAGE_MONIT) += monit
+package-$(BR2_COMPILE_MONIT) += monit
 package-$(BR2_PACKAGE_MPD) += mpd
 package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
 package-$(BR2_PACKAGE_MTD) += mtd
index 3410a992c7b9cad14dee8b6d0bdb1146e7f091dc..2472158895fc3437e3a629e0d6299a21328bedd7 100644 (file)
@@ -1,10 +1,31 @@
+config BR2_COMPILE_MONIT
+       bool
+       default n
+       depends BR2_PACKAGE_MONIT || BR2_PACKAGE_MONIT_NOSSL
+
 config BR2_PACKAGE_MONIT
-       tristate "monit - System services monitoring utility"
+       tristate "monit - System services monitoring utility, with SSL support"
+       select BR2_COMPILE_MONIT
        select BR2_PACKAGE_LIBPTHREAD
+       select BR2_PACKAGE_LIBOPENSSL
        default m if CONFIG_DEVEL
        help
-         utility for monitoring services on a Unix system
+         An utility for monitoring services on a Unix system
+         
+         This package is built with SSL support.
+         
+         http://www.tildeslash.com/monit/
+         
+
+config BR2_PACKAGE_MONIT_NOSSL
+       tristate "monit-nossl - System services monitoring utility, without SSL support"
+       select BR2_COMPILE_MONIT
+       select BR2_PACKAGE_LIBPTHREAD
+       default m if CONFIG_DEVEL
+       help
+         An utility for monitoring services on a Unix system.
+         
+         This package is built without SSL support.
          
          http://www.tildeslash.com/monit/
          
-       
\ No newline at end of file
index bbb7c867018b26cc3c140872b5eba584d8ad6223..ce4b7389070b2460c893f2eb13a0ba3cc240c167 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=monit
-PKG_VERSION:=4.5.1
+PKG_VERSION:=4.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=0f054ac39822b4be71789d49e4813754
+PKG_MD5SUM:=4e53aa44e4ca264e61c7c401cee4e697
 
 PKG_SOURCE_URL:=http://www.tildeslash.com/monit/dist/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,37 +16,72 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,MONIT,monit,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MONIT_NOSSL,monit-nossl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ifneq ($(BR2_PACKAGE_MONIT),)
+       ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/sbin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --without-ssl \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/sbin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --with-ssl \
+                       --with-ssl-dir="$(STAGING_DIR)/usr" \
        );
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR)
+       ( cd $(PKG_BUILD_DIR); mv monit monit-ssl; )
+endif
+ifneq ($(BR2_PACKAGE_MONIT),)
+       ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/sbin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --without-ssl \
+       );
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       ( cd $(PKG_BUILD_DIR); mv monit monit-nossl; )
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+endif
        touch $@
 
 $(IPKG_MONIT):
@@ -55,6 +90,16 @@ $(IPKG_MONIT):
        install -d -m0755 $(IDIR_MONIT)/etc/init.d
        install -m0755 ./files/monit.init $(IDIR_MONIT)/etc/init.d/monit
        install -d -m0755 $(IDIR_MONIT)/usr/sbin
-       cp -fpR $(PKG_BUILD_DIR)/monit $(IDIR_MONIT)/usr/sbin/
-       $(STRIP) $(IDIR_MONIT)/usr/sbin/monit
+       install -m0755 $(PKG_BUILD_DIR)/monit-ssl $(IDIR_MONIT)/usr/sbin/monit
+       $(RSTRIP) $(IDIR_MONIT)
        $(IPKG_BUILD) $(IDIR_MONIT) $(PACKAGE_DIR)
+
+$(IPKG_MONIT_NOSSL):
+       install -d -m0755 $(IDIR_MONIT_NOSSL)/etc
+       install -m0600 $(PKG_BUILD_DIR)/monitrc $(IDIR_MONIT_NOSSL)/etc/
+       install -d -m0755 $(IDIR_MONIT_NOSSL)/etc/init.d
+       install -m0755 ./files/monit.init $(IDIR_MONIT_NOSSL)/etc/init.d/monit
+       install -d -m0755 $(IDIR_MONIT_NOSSL)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/monit-nossl $(IDIR_MONIT_NOSSL)/usr/sbin/monit
+       $(RSTRIP) $(IDIR_MONIT_NOSSL)
+       $(IPKG_BUILD) $(IDIR_MONIT_NOSSL) $(PACKAGE_DIR)
index d1d6ce6f34985cca83b3028a18bc1ce0677c0948..50b18de149597aa65ca97ad6e74113c05fa9e995 100644 (file)
@@ -14,8 +14,12 @@ case $1 in
  stop)
   [ -f $PID_F ] && kill $(cat $PID_F)
   ;;
+ restart)
+  $0 stop
+  $0 start
+  ;;
  *)
-  echo "usage: $0 (start|stop)"
+  echo "usage: $0 (start|stop|restart)"
   exit 1
 esac
 exit $?
diff --git a/openwrt/package/monit/ipkg/monit-nossl.conffiles b/openwrt/package/monit/ipkg/monit-nossl.conffiles
new file mode 100644 (file)
index 0000000..365679c
--- /dev/null
@@ -0,0 +1 @@
+/etc/monitrc
diff --git a/openwrt/package/monit/ipkg/monit-nossl.control b/openwrt/package/monit/ipkg/monit-nossl.control
new file mode 100644 (file)
index 0000000..8a23d7e
--- /dev/null
@@ -0,0 +1,7 @@
+Package: monit-nossl
+Priority: optional
+Section: admin
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: An utility for system services monitoring, without SSL support.
+Depends: libpthread
index e3a4f2c01791df071155a827e6db2eaff201d3c6..3f472aec78e01c1bfed2fd89d50ec082991d7937 100644 (file)
@@ -3,5 +3,5 @@ Priority: optional
 Section: admin
 Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
 Source: buildroot internal
-Description: an utility for system services monitoring
-Depends: libpthread
+Description: An utility for system services monitoring, with SSL support.
+Depends: libpthread, libopenssl