libgcrypt needs the libgpg-error config script in $(STAGING_DIR)/usr/bin
authorFelix Fietkau <nbd@openwrt.org>
Mon, 13 Oct 2008 15:42:57 +0000 (15:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 13 Oct 2008 15:42:57 +0000 (15:42 +0000)
SVN-Revision: 12972

libs/libgpg-error/Makefile

index 7e84196a83bf4191e97dcef63666e133b9aa0400..416a922f8f2d71a8336f7b1aee04a1261612989e 100644 (file)
@@ -50,13 +50,14 @@ define Build/Configure
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_DIR) $(2)/bin $(1)/usr/bin
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/gpg-error-config \
                $(2)/bin/
        $(SED) \
                's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
                $(2)/bin/gpg-error-config
+       ln -sf $(STAGING_DIR)/host/bin/gpg-error-config $(1)/usr/bin/gpg-error-config
 
        $(INSTALL_DIR) $(1)/usr/include
        $(INSTALL_DATA) \