fix yealink kmod compile
authorFelix Fietkau <nbd@openwrt.org>
Sat, 21 Jul 2007 01:00:42 +0000 (01:00 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 21 Jul 2007 01:00:42 +0000 (01:00 +0000)
SVN-Revision: 8089

package/kernel/modules/usb.mk
target/linux/generic-2.6/config-2.6.22
target/linux/generic-2.6/config-template

index 22c1d0b2a374187c56e276ef2badc894dac66772..ac5fa109a2f311705f8e7390cbf5a517012d8e9b 100644 (file)
@@ -407,7 +407,7 @@ define KernelPackage/usb-yealink
   $(call usbdep,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
   TITLE:=USB Yealink VOIP phone
   DESCRIPTION:=Kernel support for Yealink VOIP phone
-  KCONFIG:=CONFIG_USB_YEALINK
+  KCONFIG:=CONFIG_USB_YEALINK CONFIG_INPUT_YEALINK CONFIG_INPUT=m CONFIG_INPUT_MISC=y
   FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/yealink.ko
   AUTOLOAD:=$(call AutoLoad,70,yealink)
 endef
index e498b8e79f964aa01a39056a34521b895967eee8..578bbc5444e47383810dd6db0aa8282c2c16c557 100644 (file)
@@ -441,19 +441,26 @@ CONFIG_INIT_ENV_ARG_LIMIT=32
 # CONFIG_INOTIFY is not set
 # CONFIG_INOTIFY_USER is not set
 # CONFIG_INPUT is not set
+# CONFIG_INPUT_ATI_REMOTE is not set
+# CONFIG_INPUT_ATI_REMOTE2 is not set
 # CONFIG_INPUT_EVBUG is not set
 CONFIG_INPUT_EVDEV=m
 # CONFIG_INPUT_FF_MEMLESS is not set
 # CONFIG_INPUT_JOYDEV is not set
 # CONFIG_INPUT_JOYSTICK is not set
 # CONFIG_INPUT_KEYBOARD is not set
+# CONFIG_INPUT_KEYSPAN_REMOTE is not set
 # CONFIG_INPUT_MISC is not set
 # CONFIG_INPUT_MOUSE is not set
 # CONFIG_INPUT_MOUSEDEV is not set
+# CONFIG_INPUT_PCSPKR is not set
 # CONFIG_INPUT_POLLDEV is not set
+# CONFIG_INPUT_POWERMATE is not set
 # CONFIG_INPUT_TABLET is not set
 # CONFIG_INPUT_TOUCHSCREEN is not set
 # CONFIG_INPUT_TSDEV is not set
+# CONFIG_INPUT_UINPUT is not set
+# CONFIG_INPUT_WISTRON_BTNS is not set
 # CONFIG_IOSCHED_AS is not set
 # CONFIG_IOSCHED_CFQ is not set
 CONFIG_IOSCHED_DEADLINE=y
index 1b3835dbaf04469d17884b6915bed885ec52d727..3fe20fcf44e5e45f7164227a1423d6d73cad5183 100644 (file)
@@ -428,17 +428,24 @@ CONFIG_INIT_ENV_ARG_LIMIT=32
 # CONFIG_INOTIFY is not set
 # CONFIG_INOTIFY_USER is not set
 # CONFIG_INPUT is not set
+# CONFIG_INPUT_ATI_REMOTE is not set
+# CONFIG_INPUT_ATI_REMOTE2 is not set
 # CONFIG_INPUT_EVBUG is not set
 CONFIG_INPUT_EVDEV=m
 # CONFIG_INPUT_FF_MEMLESS is not set
 # CONFIG_INPUT_JOYDEV is not set
 # CONFIG_INPUT_JOYSTICK is not set
 # CONFIG_INPUT_KEYBOARD is not set
+# CONFIG_INPUT_KEYSPAN_REMOTE is not set
 # CONFIG_INPUT_MISC is not set
 # CONFIG_INPUT_MOUSE is not set
 # CONFIG_INPUT_MOUSEDEV is not set
+# CONFIG_INPUT_PCSPKR is not set
+# CONFIG_INPUT_POWERMATE is not set
 # CONFIG_INPUT_TOUCHSCREEN is not set
 # CONFIG_INPUT_TSDEV is not set
+# CONFIG_INPUT_UINPUT is not set
+# CONFIG_INPUT_WISTRON_BTNS is not set
 # CONFIG_IOSCHED_AS is not set
 # CONFIG_IOSCHED_CFQ is not set
 CONFIG_IOSCHED_DEADLINE=y