[packages] freetype: tweak sed-ifications in freetype-config for version detection...
authorNicolas Thill <nico@openwrt.org>
Thu, 4 Oct 2007 10:15:49 +0000 (10:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 4 Oct 2007 10:15:49 +0000 (10:15 +0000)
SVN-Revision: 9117

libs/freetype/Makefile

index 6a7317fcda1b506f267d3da97a13694a1e5dab90..929ba4ec96bd94c93ac2c0f74d4fc78040cdb448 100644 (file)
@@ -59,9 +59,9 @@ define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$$includedir/freetype2,-I$(STAGING_DIR)/usr/include/freetype2,g' $(STAGING_DIR)/usr/bin/freetype-config
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$$includedir/freetype2,-I$(STAGING_DIR)/usr/include/freetype2,g' $(STAGING_DIR)/usr/bin/freetype-config
-       $(SED) 's,-I$$$${includedir}/freetype2,-I$(STAGING_DIR)/usr/include/freetype2,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
-       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
+       $(SED) 's,/usr/include/freetype2/,$(STAGING_DIR)/usr/include/freetype2/,g' $(STAGING_DIR)/usr/bin/freetype-config
+       $(SED) 's,^includedir=.*,includedir=$(STAGING_DIR)/usr/include,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
+       $(SED) 's,^libdir=.*,libdir=$(STAGING_DIR)/usr/lib,g' $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc
 endef
 
 define Build/UninstallDev
 endef
 
 define Build/UninstallDev