Add smproxy package.
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 31 Dec 2008 13:55:11 +0000 (13:55 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 31 Dec 2008 13:55:11 +0000 (13:55 +0000)
SVN-Revision: 13781

Xorg/xorg/app/smproxy/Makefile [new file with mode: 0644]

diff --git a/Xorg/xorg/app/smproxy/Makefile b/Xorg/xorg/app/smproxy/Makefile
new file mode 100644 (file)
index 0000000..57e3b89
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=smproxy
+PKG_RELEASE:=1
+PKG_VERSION:=1.0.2
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/app
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_MD5SUM:=31da204a0255ba8c6a65386e65dc1c90
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/smproxy
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  DEPENDS:=+libXt +libXmu
+  TITLE:=smproxy
+  URL:=http://xorg.freedesktop.org/
+endef
+
+define Package/smproxy/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/* \
+               $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,smproxy))