rb532: image: fix broken ifneq statement
authorGabor Juhos <juhosg@openwrt.org>
Tue, 24 Sep 2013 13:17:39 +0000 (13:17 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 24 Sep 2013 13:17:39 +0000 (13:17 +0000)
Fixes the following build error:

  /devel/openwrt/staging_dir/host/bin/patch-cmdline \
  /devel/openwrt/build_dir/target-mipsel_uClibc-0.9.33.2/linux-rb532/vmlinux-initramfs \
  'root=/dev/mtdblock1 rootfstype=yaffs2 '
  Could not open kernel imagemake[5]: *** [install] Error 255

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38157

target/linux/rb532/image/Makefile

index fea6c94198c9a3245cca722094e93f8e108c10cb..5f421bbe2804b9cefb338717d0c14acb316ae972 100644 (file)
@@ -63,7 +63,7 @@ define Image/Build
        ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).bin 4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
 endef
 
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
   define Image/Prepare
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-initramfs '$(strip $(call Image/cmdline/yaffs2)) '
        cat $(KDIR)/vmlinux-initramfs | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux-initramfs.lzma