[package] openldap: add slapd.conf to the package and mark it as config file
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 16 Jan 2010 13:47:33 +0000 (13:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 16 Jan 2010 13:47:33 +0000 (13:47 +0000)
SVN-Revision: 19168

libs/openldap/Makefile

index c219ff26093df84036aac1817796d47708d37591..17f62dd7559cf3de187ac7a4bf60c532498d770e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.19
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
@@ -73,6 +73,10 @@ define Package/openldap-server/description
        This package contains server programs required to provide LDAP services.
 endef
 
        This package contains server programs required to provide LDAP services.
 endef
 
+define Package/openldap-server/conffiles
+/etc/openldap/slapd.conf
+endef
+
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
@@ -106,16 +110,16 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libopenldap/install
        $(INSTALL_DIR) $(1)/etc/openldap
 endef
 
 define Package/libopenldap/install
        $(INSTALL_DIR) $(1)/etc/openldap
-       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
 endef
        
 define Package/openldap-utils/install
 endef
        
 define Package/openldap-utils/install
@@ -127,7 +131,8 @@ define Package/openldap-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ldap.init $(1)/etc/init.d/ldap
        $(INSTALL_DIR) $(1)/etc/openldap/schema
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ldap.init $(1)/etc/init.d/ldap
        $(INSTALL_DIR) $(1)/etc/openldap/schema
-       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/sbin
        # OpenLDAP installs slapd into libexecdir, not sbindir:
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/sbin
        # OpenLDAP installs slapd into libexecdir, not sbindir:
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/