brcm63xx: Add profile and build image for Sagemcom F@ST2704V2 ADSL router
authorJonas Gorski <jogo@openwrt.org>
Sat, 22 Feb 2014 11:16:35 +0000 (11:16 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 22 Feb 2014 11:16:35 +0000 (11:16 +0000)
This adds profile and build image for Sagemcom F@st2704, using b43
driver.
For WiFi to work properly BCMA fallback SPROM support patch must
be applied (http://git.io/z1Ki8A).

Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
Patchwork: http://patchwork.openwrt.org/patch/4212/
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 39673

target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile

diff --git a/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk b/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk
new file mode 100644 (file)
index 0000000..ebe1755
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sagemcom-2704V2
+  NAME:=Sagemcom F@ST 2704 V2
+  PACKAGES:=kmod-b43 wpad-mini \
+    kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev 
+endef
+define Profile/Sagemcom-2704V2/Description
+  Package set optimized for Sagemcom F@ST 2704 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,Sagemcom-2704V2))
index dc11c33705b31d719b85ebc54adc9494190dc964..e0bcb07d61297d6c5cfcfaecbf241545f04d82ce 100755 (executable)
@@ -255,6 +255,9 @@ define Image/Build
        # Sagem F@ST2604
        $(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604-cfe)
        $(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604,OpenWRT-$(REVISION))
+       # Sagem F@ST2704V2
+       $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2-cfe)
+       $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
        # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0