lantiq: use sysupgrade.bin postfix for tplink images
authorJohn Crispin <john@openwrt.org>
Mon, 2 May 2016 18:50:10 +0000 (18:50 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 May 2016 18:50:10 +0000 (18:50 +0000)
Use the same name for TP-Link images as it was with the old image build
code.

Move the BOARD_ID export to the TP-Link image build recipe, to indicate
that the variable is only related in this context.

Signed-off-by: Mathias Kresin <openwrt@kresin.me>
SVN-Revision: 49279

target/linux/lantiq/image/Makefile

index f779a1b936ea3acf85ee1720e0fc7c9915385f0f..033dcc32b48a569abb20cdee06c0171dc1f98eed 100644 (file)
@@ -283,14 +283,15 @@ define Device/Default
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs
 endef
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs
 endef
-DEVICE_VARS += BOARD_ID DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
 
 define Device/lantiqTpLink
   KERNEL := kernel-bin | append-dtb | lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-fw
 
 define Device/lantiqTpLink
   KERNEL := kernel-bin | append-dtb | lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-fw
-  IMAGES := tplink
-  IMAGE/tplink := mktplinkfw2
+  IMAGES := sysupgrade.bin
+  IMAGE/sysupgrade.bin := mktplinkfw2
 endef
 endef
+DEVICE_VARS += BOARD_ID
 
 define Device/lantiqBrnImage
   KERNEL := kernel-bin | append-dtb | mkbrncmdline | lzma-no-dict
 
 define Device/lantiqBrnImage
   KERNEL := kernel-bin | append-dtb | mkbrncmdline | lzma-no-dict