hey, this patch should fix #4026.
authorFlorian Fainelli <florian@openwrt.org>
Sat, 27 Sep 2008 14:24:50 +0000 (14:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 27 Sep 2008 14:24:50 +0000 (14:24 +0000)
currently, mpd depends on libsamplerate:
michux at fwpiercer:~/trunk2/trunk$ objdump -p
build_dir/mipsel/mpd-0.13.2/src/mpd | grep NEEDED
   NEEDED      libnsl.so.0
   NEEDED      libsamplerate.so.0  <<<<
   NEEDED      libasound.so.2
   NEEDED      libdl.so.0
   NEEDED      libpthread.so.0
   NEEDED      libiconv.so.2
   NEEDED      libid3tag.so.0
   NEEDED      libz.so.1
   NEEDED      libmad.so.0
   NEEDED      libFLAC.so
   NEEDED      libm.so.0
   NEEDED      libvorbisidec.so.1
   NEEDED      libgcc_s.so.1
   NEEDED      libc.so.0

libsamplerate is quite large:
1336652 2008-09-21 06:17 bin/packages/mipsel/libsamplerate_0.1.3-2_mipsel.ipk

so it would make sense to compile mpd per default without
libsamplerate, as more than 1 mb for a feature you probably don't need
is quite a waste of space...

cheers
michu

Signed-off-by: Michael Vogt <michu at neophob.com>
---

SVN-Revision: 12729


No differences found