ar71xx: image: allow to use optional parameters for MkuImageLzma/initramfs
authorGabor Juhos <juhosg@openwrt.org>
Tue, 5 Nov 2013 18:41:18 +0000 (18:41 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 5 Nov 2013 18:41:18 +0000 (18:41 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38658

target/linux/ar71xx/image/Makefile

index 811da74bcf618473636a3969a8d161cc0fddeb4c..c934dd4adc124e1f79fedabb9076b86020520826 100644 (file)
@@ -91,8 +91,8 @@ define MkuImageLzma
 endef
 
 define MkuImageLzma/initramfs
-       $(call PatchKernelLzma,$(1),$(2),,-initramfs)
-       $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-initramfs-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
+       $(call PatchKernelLzma,$(1),$(2),$(3),-initramfs)
+       $(call MkuImage,lzma,$(4),$(KDIR_TMP)/vmlinux-initramfs-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
 endef
 
 define MkuImageGzip