[package] provide a screenrc (#5958)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 18:17:51 +0000 (18:17 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 18:17:51 +0000 (18:17 +0000)
SVN-Revision: 18210

utils/screen/Makefile
utils/screen/files/etc/screenrc [new file with mode: 0644]

index c308ad6a0a6d6ea79f3e190d6932fff1b6edfb96..97a53b6de494383cf768d4dc9b74cc40229acfbb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=screen
 PKG_VERSION:=4.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/utilities/screen \
@@ -32,7 +32,8 @@ define Package/screen/description
 endef
 
 define Build/Configure
-       $(call Build/Configure/Default,,\
+       $(call Build/Configure/Default,\
+               --with-sys-screenrc=/etc/screenrc,\
                LIBS="-lcrypt" \
        )
 endef
@@ -40,6 +41,8 @@ endef
 define Package/screen/install  
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/screen $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/etc/screenrc $(1)/etc/screenrc
 endef
 
 $(eval $(call BuildPackage,screen))
diff --git a/utils/screen/files/etc/screenrc b/utils/screen/files/etc/screenrc
new file mode 100644 (file)
index 0000000..3337674
--- /dev/null
@@ -0,0 +1 @@
+startup_message off