package/kernel: add module for the Booke watchdog
authorGabor Juhos <juhosg@openwrt.org>
Sun, 29 Apr 2012 15:00:37 +0000 (15:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 29 Apr 2012 15:00:37 +0000 (15:00 +0000)
Based on a patch by Wojciech Dubowik <Wojciech.Dubowik@neratec.com>

SVN-Revision: 31522

package/kernel/modules/other.mk

index d3450cf73bafbf725f062c4d6df48f0e0efbf393..d6eab58704896a3d7df5235f30c463616dde3f44 100644 (file)
@@ -720,6 +720,24 @@ endef
 $(eval $(call KernelPackage,wdt-ath79))
 
 
+define KernelPackage/booke-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PowerPC Book-E Watchdog Timer
+  DEPENDS:=@(TARGET_mpc85xx||TARGET_ppc40x||TARGET_ppc44x)
+  KCONFIG:=\
+       CONFIG_BOOKE_WDT_DEFAULT_TIMEOUT=38 \
+       CONFIG_BOOKE_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/booke_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,booke_wdt)
+endef
+
+define KernelPackage/booke-wdt/description
+  Kernel module for PowerPC Book-E Watchdog Timer.
+endef
+
+$(eval $(call KernelPackage,booke-wdt))
+
+
 define KernelPackage/pwm
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PWM generic API